Solid Tools and Outer Shell


#1

Hello,
I use SketchUp 7 Pro. I cannot fine Solid Tools and Outer Shell from Tool menu. How can get this tool bar works?

Thanks for any help
Jie


#2

Solid Tools functions were introduced in Sketchup 8 Pro.


#3

Thanks!
I got the tool on Sketchup 8 Pro. But once I use these tools (such Union, Subtract), the pop window just shows “One or more of the selected objects is either not a solid or is locked…” So is there any way to make all those be a solid model?


#4

The SOLID tools require that groups or components be SOLID. Yes, there’s a way to make solids but you’ve given no information about what you’ve actually got. Are you making groups or components? Why don’t you share the SKP file so there’s some hope of getting you the help you need?


#5

where is the share location I can put the SKP file?


#6

Use the upload button at the top of the reply window of this forum:
Files are limited to 3MB max.

To add some detail to what Dave asked, in SketchUp only Groups or ComponentInstances can be solids. To be a solid, they have to pass a set of tests that basically amount to being a single shell that encloses a volume without any holes or extra edges and faces that aren’t part of the shell surface. Edges and Faces that stick into the interior are not allowed.


#7

The file has about 40 MB


#8

Maybe you can save just the part you are trying to work with the Solid tools on ?


#9

Yes, it is a part I want to be solid


#10

You could also upload it to the 3D Warehouse and share the link here. If you do that, make sure it is public.


#11

Go to Window > Model Info > Statistics > click ‘Purge Unused’.
Save and re-load the file to see if it has decreased enough in size to upload.


#12

It is still 16 MB. I will find another part as an example.
Thanks


#13

I cannot get small sized model. I did a model by AutoCAD and imported to Sketchup. However, the model in sketchup is broken on some surfaces. Is there any way to fix it?

model from cad.skp (248.2 KB)


#14

It looks like the issue is all the holes in your model. If you look at the two models below, the original is full of holes. These have to be closed up before SketchUp will see them as solids:

The other issue you will need to address is that all three “masses” are in a single group. They will need to be exploded out of the group and individually grouped.


#15

Something else to consider is the extraneous geometry in the file. The file you posted has a LOT of extra lines:

While these lines won’t prevent solid tools from working, you may want to address them if you plan to do a whole lot more with this model.


#16

Many of the (hidden) lines @TheOnlyAaron points out result from edges that look straight but are not really quite straight, hence are broken into segments. If you turn on endpoints in the style you can easily see all these broken lines. Without knowing your intent, I don’t know whether these subtle curves are deliberate or resulted from slight sloppiness in the CAD model, but they make it much harder to clean up.


#17

Your fixed model is very nice. How do you make it?
Yes. the model I posted has a lot of extra lines, I don’t know why. The model is created by autocad and it looks nice in autocad. Is that something I missed when imported to sketchup?


#18

often, posting the original will reveal if it is an export or import setting that needs adjusting…

john


#19

The original model has holes I don’t want, but the picture of the left side model is pretty good, seems it has adjusted. Could you show me how to do it? Any such video in YouTube?


#20

What I did was turn on hidden geometry and draw lines to close the holes with triangular surfaces. I can do a quick gif in the morning (at home on my phone, now) to show the process (unless a sage beats me to it…)