Solid SketchUp Shape has many errors when viewed in Simply3D for 3D printing


#1

The shape shows as solid in SketchUp and Solid Inspector 2 says it’s solid but Simply3D shows many errors.
Here’s a screenshot and the SketchUp file for the solid shape:


Wine Glass_solid group.skp (1.6 MB)

Here’s an image of what the shape looks like in Simply3D:

I’m not really optimistic about anyone being able to help me. If I can’t fix this I’ll have to stop using SketchUp and try using some other 3D modeling software that doesn’t have these problems.

I really would appreciate the attempt to help me since I have already had a great deal of help here on this forum.


#2

This appears the same model you had us look at before.? If you are referring to the triangles some programs automatically do that but, does not mean it is bad. I checked the model in Netfabb for the orginal post and it checked out fine. Make sure you make the correction originally suggested, especially the reversed faces,


#3

Yes this is the same model I had you look at before. The person who is doing the 3D printing for me is telling me it’s not good because of the red lines that appear when the model is loaded into Simply3D and viewed. Yes I did reverse the faces and heled the bottom. that’s why it shows as solid in SketchUp.


#4

Remove the dimensions, guides etc from within the group.
Ensure if contains only edges and faces, and that it reports as ‘solid’ in entity-info.
Now select the group and use the context-menu ‘smooth’ tool to ‘unsmooth’ it [0 settings] so all edges show.
Now edit the group [double-click to open it or context-menu item…].
Then use Edit > Select All and use the context-menu Intersect > with Selection.
Exit the edit and select the group.
Does entity-info still report it as a solid ?
If not, then although SketchUp saw it as solid it was not 3D-printable because forms were self intersecting…

Try and fix the issues until it reports as a ‘solid’ again’.

Repeat this until it reports as a ‘solid’ after an intersection…


#5

It’s interesting. I told you yesterday to not include the dimensions in the group but they still appear to be inside it. As TIG said, remove them.


#6

I ran through real quick and erased everything in the group that was not geometry (guidelines and dimensions) as @TIG Suggested then exported a .STL file and looked at it in Makerware… Looks good, from here!


#7

Here’s the message I got when trying to Intersect Faces with selection:


#8

That’s OK then !

Although perhaps you did choose to intersect it with the model rather that the selection as instructed - the outcome is the same.

As Aaron says, removing everything that is not an edge or a face is likely to fix it is this case.

I was just suggesting the worst case scenario…


#9

This topic was automatically closed after 91 days. New replies are no longer allowed.