Solid part issue

Hawk_connect.skp (43.4 KB)
Any advice or help to make this part a solid? I am fairly new to Sketchup and can’s seem to get this part to print properly. The bottom detail is printing as a solid flat surface.

1 Like

You’re missing a face in the bottom of the groove on the bottom of the part.

Use the Line tool to draw some lines between inned and outer circle to create the face.

Also correct the reversed back faces. Do not simply paint them with a material. That doesn’t fix the reversed faces.

1 Like

Thanks Dave!

Dave - how are the reversed faces corrected?

Easiest is to select a correctly oriented face, right click on it and choose Orient Faces. Set the Face Style to Monochrome so you can see the blue back faces.

This is a thing you should stay on top of as you are modeling. It’s generally easier to clean up as you go and correct face orientation is critical for 3D printing.

1 Like

A couple of other things about your modeling for 3D printing.

First, you shouldeither choose a different template or at least change the units from Architectural to Fractional or Decimal and Inches or Millimeters. Then turn off Length Snapping.

When I model for 3D printing I use meters as the units and leave the model huge. Your part would be modeled with a 1.5 meter radius. Then export the .stl with units set to meters and import into the slicer with units set to inches. I redrew your part that way and was able to use a larger number of sides for the circles.

Note that there are some situations that defeat the logic of Orient Faces, particularly when two otherwise disjoint portions of an object meet along an edge. Of course, that situation violates the rules for a solid too.

orient faces

1 Like

Huge help! and thank you for the great advice and suggestions.


That specific joint will fail to produce a solid too due to the zero point. It is a very close relative of the bowtie issue.

1 Like