Soften Edges in select context menu: bug?


#1

Hi,

Selecting ONE single edge displays a context menu line “Soften”. Clicking it works OK.
Selecting MORE than one entity ( edge(s),face(s) ), displays context menu “Soften/Smooth Edges”. Clicking it - nothing happens! Could it be a bug?
Actually, the reverse thing really works. After “show hidden” and selecting >1 entities, clicking “Soften/Smooth Edges” it will unsoften the edges OK.
The only work around this “Soften/Smooth”-bug is by “painting” with Ctr+Eraser-tool, which unfortunately is extremely time consuming and unusable on big complex components.
Have I got this all wrong or is it a bug and in that case - how soon could we hope for it to be fixed?

Soften works OK when one single edge selected:

Soften/Smooth Edges NOT working when more than one entity selected:

Hopeless using Ctr+Eraser-tool to soften many edges:

If this is a hardware/software issue my PC is:
Windows 10 Pro vers 1703, Intel®Core™ i7-3770K
CPU 3.50GHz 64-bit architecture 32718MB/33GB RAM

Regards

cstrom


#2

If it is only one edge it will just soften it, but if you have selected more than one the option changes, it opens the Soften Edges dialog with a few more options and a sliding scale.


#3

Problem solved!

Thank you Box for extremely quick answer!
You put me on the right track here. The remaining issue was - how to select some 1000 edges?
So I just installed the fantastic free plugin “Selection Toys” (by ThomasThomassen, thomas@thomthom.net). By first selecting all thousands edges in the component, then right-clicking Selection Toys expanded context menu Deselect->Faces, your method using the Soften Edges dialog option “Soft” does the job. Amazing! Thanks again!


#4

It’s a brilliant plugin, but you don’t actually need it for what you describe. Just select all your shapes, faces and all, and adjust the slider.

By the way, if you have 1000 of them all the same, you’d be better off making one as a component and 999 copies, then all you need to do is soften the edges on one and all the rest will follow.


#5

I noticed that the slider won’t show if both edges and faces are selected. Still seems like I need the plugin to deselect all faces before the slider can be accessed. (The slider is another great thing, as you mention, btw!)

About the big component: I only created it as an example here. In the real workflow one might come across big and much more geometrical complicated forms that must be edited with soft and unsoft etc. So I just wanted to learn how to handle that in the future. But thanks for the useful tip!

And for now, I am happy as a child, having learned to control most(?) of the amazing graphic possibilities that SketchUp has when combining hide/soft/smooth with the rest of the modelling capabilities!


#6

It should, it certainly does for me.


#7

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.