Add a shortcut or fix the soften function?

I’m in the middle of doing a few hundred “L-click, R-click, Soften” functions as SU refuses to soften multiple lines at once.

Either add this to the softcut list or fix the function. My hand is killing me…

Why not select all the geometry, right click and choose Soften/Smooth from the context menu? Then adjust the slider in the Soften Edges window? If the Soften Edges window is already open, you don’t need to right click at all.

If you really must have a keyboard shortcut, you can create your own.

If edges don’t get softened when you try to soften them en masse, perhaps they are coplanar edges and need to be erased instead of softened. This would be common with imported STL files, for example. While those edges could be softened (you could even tick the box for Soften coplanar, it would make more sense to erase those edges since they aren’t needed and just add to file bloat.

I’m using it to hide them. I do not want them to be unhidden if I use “unhide all” which I do quite often.

I’m not rounding an object.

I’m not using smooth edges, I’m using soften from the right-click context menu on single lines. I have tried selecting a bunch of them then click soften with no effect. It only seems to work with single lines.

They are not coplanar. The only reason I am hiding them is that they break the plane when deleting them.

Edit: I do not have Edit/Item/Soften/Smooth Edges in my shortcut menu.

You will if you have an edge selected when you go to the shortcut menu.

No, I mean in here:

It’s those lines on the teeth I am working on. They are exploded components that are apparently not exactly planar.

I repeat. Select at least one edge then go to the shortcut menu.

Ok, that preference window being sensitive to what you have selected in the menu is a dumb feature to me. Why not just show all of them.

I got it. I had no clue the context was linked to the model.

Thank you for the help @DaveR and @Box. You have saved me a lot of pain. :confounded:

You guys always seem to be able to help me after hours of trying to fix it myself. :kissing_heart:

The list in menu Window > (system) Preferences > Shortcuts is context sensitive (like @Box mentioned)
If you have a face and some edges selected you’ll see Edit/Item/Soften/Smooth Edges. See @DaveR’s reply above. (Does not work for me as to smoothing edges as well)
If you only have an edge selected you’ll see Edit/Item/Soften in the list. Assign a key to this option, say [N] as an example.

Now you can hover over edges with only the (say) ‘Move’ tool selected, no geometry, nothing else.
Hover over your geometry and hold down the shortcut key [N] to see all the edges under the cursor being softened.
The ‘Eraser’ tool, while holding down [Ctrl], does almost the same thing: it softens plus smooth all edges under the cursor.


Wow I didn’t see that modifier for the eraser tool. That makes it even faster! Thanks @Wo3Dan!

I’d be interested to see a sample model in which that doesn’t work.

Sorry. I figured you already knew about that option.

1 Like

Unfortunately that part of the model I was working on is complete. If I run into it again, I’ll post it.

I have been using SU for many years and still find features I didn’t know existed. Good and bad…

Like the instant crash feature when I work with toothed belts. That’s a fun one.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.