Snapping to Edge and Duplicate Faces issues

Hi there,

I have noticed that when i am modelling i often get overlapping faces or duplicate faces by just drawing a line through a face. It is quite irritating and ends up costing me more time when i have deadlines for projects. The other issue i get is that sometimes i can’t snap to edges properly as if there is something in between the line tool and edge i am trying to select. I’ve checked and saw no hidden objects, my edges are on in the styles settings. Also, when i group something like a simple rectangular block for example then try to open the group by triple click the face - it seems to select through the objects. I am not in xray or wire frame mode. I have no idea why it happens.

Please help!!!

Could you attach a model that displays these issues so we can check it.

Hi Please see the attached Mdoel.

The following Extensions i am using:

  • 1001bit tools
  • fredo curviloft
  • fredo joint push/pull
  • fredo scale
  • fredo round corner
  • fredo tools on surface
  • pipe along path
  • sketchuv
  • Solar North
  • solid inspector
  • vertex tools
  • vray
  • subd
    Thanks,

i also have length snapping off just in case you propose that too.

I’m sorry, I’m not in a position to download a 102mb file.

okay give me a second and ill just reduce it to one wall or block.

see the link below:
Model with issues.skp (4.3 MB)

Can you point out places on the simplified model where you encounter these issues? I see one rectangle that has z-fighting because it is on the same plane as the floor but in a different group. Is that what you mean?

The main issue I see is incorrect usage of Layers/Tags.
You have raw geometry on mixed layers.
The Field of view is rather extreme.
The advanced camera may also be causing issues.

The only bugs I see appear to be due to incorrect and imprecise modeling practices, not a problem with SketchUp.

2 Likes

Hi Please see the screenshot attached. If you try to draw a line along the wall by the lift doors then you will see that the face overlaps.

How can i solve this issue? Its never happened to me before this project.

i always use the axis to help model by locking on to them when modelling. Do you thing it could be because of tags and camera?

I’d say it has something to do with your workflow, including the layers and camera.
Is there a reason it is 63m from the origin, if you move it back the face doesn’t duplicate.

I have no idea why it’s moved. I’ll play around with it and see how to sort it out. Any tips on the camera and layer part. I’m relatively still new to understanding what’s right and what’s wrong when modelling in sketch up. Thank you

As Box points out, keep your model close to the origin. 63 meters away from the origin isn’t helping you.

As for Layers, leave Layer 0 active at all times and leave Layer 0 assigned to all edges and faces. Only assign other layers to groups and components. The geometry inside the groups and components keep the Layer 0 assignment.

As for the camera, you’ll probably do well to keep the field of view to between 25 and 35 degrees.

1 Like

Okay! Amazing! I’ll give it a try and come back to you guys if the issue is still persistent. Regarding the origin, I tend to always import cad first then model where the cad has been placed. Didn’t know much about the origin.

Probably best to deselect Preserve drawing origin in Options before importing.
Screenshot - 7_31_2020 , 9_00_00 AM

I don’t really know why it is but nearly every CAD file I’ve ever been sent for a project have been quite bad. I see this also with files that some of my students seem to get from their colleagues or clients. Most often I only use the CAD file as a rough guide and do all of the modeling myself to make sure it is correct. I rarely even trace the imported CAD file lines because that winds up creating problems.

2 Likes

I think I had preserve drawing origin on. How does that setting affect sketchup? Does it mess with the coordinates etc…?

Thanks

Many dwg files have the origin of the drawing located far from the origin point of the model coordinates. If you set “preserve drawing origin”, SketchUp imports the geometry with this same offset from the model origin. Turning it off tells SketchUp to move the drawing origin back to the model origin. Models that are located far from the model origin can cause issues in SketchUp.

If the CAD file was created at a long distance from the origin, the imported file will also be at a long distance from the origin. If you turn that off, the imported file will be placed so it’s at the origin and extending back in the positive direction from the origin.

You guys are amazing! After changing the CAD settings - i am not having these issues anymore (Touch Wood).