Snapping rotation to line/plane problems


#1

I’m just messing around, trying to level up. Drawing an icosohedron. Starting with a pentagon, create an equilateral triangle on one edge, then fold that up until the tip snaps to a normal from the center of the pentagon. Can’t do it. Can’t get it to snap. I’ve tried creating planes and circles and rotatiing only a center line and and and… probably 3 hours of messing around. Any reason this should be so hard?

If that’s not obvious: imagine a pentagon with 5 equilateral triangles hanging off the edges. Now fold them all up until their apexes (apices?) meet. That’s what I’m trying to do…


#2

I did finally get this to work by creating a circle centered on a pentagon corner, intersecting the tip of the equilateral triangle, and rotating it up, but I don’t think it is actually right, since the 3 sides of the triangle thus created are several thousandths of an inch off, which feels like more than rounding error. It just seems allergic to snapping to an intersection involving the axis, including if I’ve drawn a line on the (normal) axis…


#3

I’d use Rotation by selection of plane and angle which is a tool in Fredoscale.


#4

What you are showing is exactly what I’ve been trying to do, but the final snap of the folding triangle to the vertical axis never happens. I can’t get it to happen. I can’t get Fredoscale to load in 2017 right now either. Arghh. You are doing exactly what I’ve been trying to do for hours.


#5

Also, if you don’t mind: what did you record that in? That’s very helpful illustration.


#6

What do you mean? What are you doing to try to install it? Did you install LibFredo6, too?

I recorded the GIF in LICEcap. there are other options out there as well.


#7

I tried installing Fredoscale in 2017, LibFredo seemed to install but I couldn’t get FredoScale to install. In 2016 I can’t even get LibFredo to install (“contact administrator” or some such).


#8

Just for the record though: shouldn’t I be able to do that fold/snap with regular SU tools? Shouldn’t the apex of the triangle “find” the normal of the pentagon as I fold it over? Does Fredoscale change that snapping dynamic somehow?


#9

How are you trying to install them?

No.

Fredoscale allows the cursor to snap to the vertical edge as shown in my screen grab.


#10

hmm, okay. Well, here’s what I get when I try to install libfredo in 2016:

Authentication Error !

Something went wrong during the authentication process.
Please contact system administrator. Reference ID: fbad76be-6bd5-4f2a-8342-fa124bb7abba

To be fair, right now I don’t have my Pro license for either version on this machine. I’m going to try to clear that up soon (it’s on a work machine and a dead machine).
Thank you though: it sounds like Fredoscale provides the functionality that I thought Sketchup already had. I’ll get Fredoscale installed somehow.


#11

You haven’t told me HOW you’re trying to install Fredoscale or LibFredo6.


#12

Oh sorry. Extension warehouse first


#13

Are you accessing the Extension Warehouse through SketchUp?

So you didn’t follow My link? Get both from Sketchucation.


#14

Sorry… I’ve now downloaded both from Sketchucation, they appear to be installed in 2017 (2.8a & 7.2d).

So: I’m sorry, I’ve not used Fredoscale in years and never much. I start up just like normal, select the object (the triangle) place the protractor (correct the axis as necessary), select the tip of the triangle… and then it says "select point for inference)… and I’m right back to where I started. If I select the origin (center of pentagon) it still won’t snap to the normal. Whew. Frustrating.


#15

OMG. I also downloaded Licecap, to show you what was happening, and on the first attempt it snapped fine. Perfect. Incredible. That was probably the 200th time I’d tried to do this, the 10th or so with Fredoscale. Anyway, thanks very much for your help. Now I have to figure out (eventually) why it suddenly worked…