FredoCorner not acting on selections made in Sketchup

I am not sure if this is the right place to ask this, but let me try…

I was forced to update FredoCorner yesturday and now the functionalty has changed (broken)?

Normally, I highlight something in Sketchup and then select FredoCorner and the selections I made are used… But this no longer happens… The only option I have is to make my selections INSIDE FredoCorner.

I have created a short video here which shows the behavour:

https://jweaver.tinytake.com/tt/NTA5NTUyNV8xNTk5OTA1Mg

Right at the end you will see me use an OLD version of FC where the original behavour still works.

Is this a bug? And intentional change? Or is this just specific to me?

Looks to me as if the radius you have selected is too large for the dimensions of the box. Try something smaller like 5mm.

With a shape large enough to support a 50mm radius, it works fine for me.

No… Thats not it… FC is simply ignoring any of the selections I make before I launch it.

This always worked before and has only stopped since I upgraded.

I can still make my selections INSIDE FC… But I can’t make them in Sketchup before I launch

Here is another Video…

https://jweaver.tinytake.com/tt/NTA5NTYwNF8xNTk5OTIzOQ

(How exactyl do you take the videos that you make? Is that a Sketchup Plugin)?

Check to make sure you have the latest versions of both FredoCorner and LibFredo6 installed. Go to Window>LibFredo6 settings… and click on Check for updates.

I use a thing called LiceCap to make the videos like that. It’s not a SketchUp extension.

Upgraded LibFredo6 and FredoCorner at the same time… I currently have FC 2.3a (27 Jan 21) and LibFredo 11.6a (23rd Jan 21)

Do you have the license for it?

First post of this thread: [Plugin][$] FredoCorner - v2.3a - 27 Jan 21 • sketchUcation • 1

And a linked thread: SCFLicense: Extension Licensing on Sketchucation • sketchUcation • 1

Nope… Just using the free version which I have to update every few weeks.

The “old” version (RoundCorner) still works and for what I use it for, its fine… But I am just curious whats gone wrong…

FredoCorner is no longer a free extension. See the links I put in my previous reply.

oh… I assumed it was based on this:

  • Free Trial period (full features): 15 days from activation

So can I say with 100% certainty that my problem is caused by the fact that I don’t have a license?

If so, I will either have to buy it… Or just live with RoundCorner which I think does everything I want.

If you’ve updated it every few weeks, you’ve been using it for more than 15 days.

I’m kind of surprised it has taken Fredo6 so long to get to this point. I think he should have been charging for his excellent extensions years ago. They are worth the tiny cost.

1 Like

I agree… It just seems like an odd way to “police” it… Just limiting part of the functionality is odd… Why not just not launch and give and error saying “Trial Period Over”.

Cheers

There should be a message somewhere that gives you that information.

I knew it was a licensed product but believed that you could use it for free if you updated it regularly…

Its just odd to me that it still works perfectly… But one feature (that I have found) does not work, which is not normal for licensing software, atleast not in my experience.

Buit it doesnt’ matter… I get the message… And thankyou for your help.

No. That’s not how it works.

I get that now… I was sure I read that it was free “for now” and he kept forcing you to updates until this was no longer an option…

But I simply misunderstood… And for someone like me who uses FC a couple of times a year, I can live without it and will just use RoundCorner instead.

“Now” has come and gone.

On the bright side you won’t have to worry about updating Round Corner. It hasn’t changed since 2018.

:slight_smile: Thats true… Cheers…

Looks like I do have a problem, so even if I bought a license it won’t work… I got a reply from Fredo over on the Sketchnation forum and he gave me a clue to look at the Ruby console for errors.

And true enough I have one:

Error: #<NoMethodError: undefined method machine_id' for G6B:Module> c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:1720:in tem_context’
c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_fredocorner/fredocornertool.rbe:751:in activate' c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_fredocorner/fredocornertool.rbe:194:in select_tool’
c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_fredocorner/fredocornertool.rbe:194:in launch' c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_fredocorner/fredocornertool.rbe:176:in action__mapping’
c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:129:in call' c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:129:in launch_action’
c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:227:in launch_action' c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_fredocorner/bootstrap_fredocorner.rbe:103:in launch_action’
c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_fredocorner/bootstrap_fredocorner.rbe:118:in block in startup' c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:1347:in call’
c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:1347:in command_invoke' c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6plugin.rbe:1328:in block (2 levels) in build_config_commands’
c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6traductor.rbe:1377:in call' c:/users/jonpw/appdata/roaming/sketchup/sketchup 2018/sketchup/plugins/fredo6_!libfredo6/lib6traductor.rbe:1377:in block in add_command’
SketchUp:1:in `call’

But now I have looked at other Fredotools that I have installed, I can see I have other problems… For example, FredoSpline acts in exactly the same way…

I get the same error… So it seems that something is broken here… And I dont’ know how to fix it… I have tried uninstalling the Fredotools in quesiton, as well as LibFredo but that hasn’t helped…

I guess the only way might be to buy RoundCorner, and then I can request support from Fredo?

You might try repairing the SketchUp installation.