Snapping a Window into a Wall

Snaps is working really well with my dynamic components. Eg for plug points on walls I’ve set Z to the correct plug point height, so once snapped onto the wall it then just jumps down to the correct height. But one thing I’m having an issue with is getting the snap to embed a window in a wall. No matter what I do - flip the snap or rotate the snap - the window just ends up flipping and sticking out the wrong way. Could someone help me with this please?

Take a look at the placement of the window snap. Your door has the correct placement (inside)

But the windows doesn’t, the snap should be where the arrow is pointing

Please update your profile, you are using a different SketchUp version as your profile says…

Well this isn’t going to make me come across very well - but I can’t see how to update that on my profile …?

Thanks rtches. No - it is in the right location. I want the front of the black rectangle to snap to the front of the wall. That’s the window reveal. I do interiors, so I want the frame at the back of recess. Does that make sense?

Here I am trying again - this time with the snap located at the back of the cill overhang. And then to reverse the snap orientation with option > command - but it still flips the window. I’ve tried rotating the snap as well - and changed the face style to colour the front and back faces to make sure I’m doing it right - but it still flips just as before!

Click in the circle with the letter “S” next to your post and:

Share here your model and I will try for you…

Ok. Thanks. In the attached model - from left to right - I’ve got a wall with the window embedded. This is how I want my window to sit. To the right of that I’ve got the cut out for the window that I add in afterwards, just so you can see why I want it to sit like that. And the the right of that is a non-dynamic version of my DC (I don’t want to share the actual DC). I’ve added two snaps to it - one behind the cill and another at the top of the reveal lines. No matter what I do, the window flips. Very interested to see if you have the same issue!
snap test.skp (80.5 KB)

It is quite strange, at first I thought it was because of the axis of nested components but I have tried to change them and there is no way.
Actually the snaps are meant to snap together so you would have to have a snap on the wall as well for it to work.
I have tried a thousand combinations and against one side of the wall I can’t get it to work at all. Always stack perpendicular to the face whatever the snap normal axis point…
Maybe @TysonK can help you…

1 Like

Huh, this was interesting, definitely opened up some behavior I didn’t know about. (I’m not part of the dev team, so I get to learn about some of this stuff same as you!) :wink:

Based on some testing, this is the behavior I’m finding, I don’t know if this will work with your DC’s or not.

Think of the object bounding box. If a snap is placed to the front of that boundary, then the behavior will be what you are seeing - ie, regardless of the front or back face of the snap, it will try to snap the whole object to that surface, thus ‘rotating’ your window component.

So, the way to get around this is to NOT have the snap be at the outer boundary of your component. So, in this example, I’ve drawn an edge that is part of your simple outline group, and hidden that edge, but that pushes the boundary forward, beyond the snap. That seems to make that snap work as you are hoping - aligned with the wall.

You could also create another snap somewhere out in front to push the boundary, but keep other snaps as the ‘usable’ snaps.

I hope that makes sense, I hope it will work with your case. Very cool that you figured out how to make it snap to the Z regardless of where you place it on the wall.


Thanks for trying rtches and thanks for coming up with a solution TysonK.

I’ve now added a hidden subcomponent “snap balance” that seems to do the job. It seems to need to protrude in the opposite direction at least the same depth as the window itself.

It is still a little glitchy though:

  • It doesn’t work at any wall depth less than 250mm.
  • And move/copy seems to upset it. Cutting and pasting sorts it back out though.

For anyone interested here are few videos of it …

  1. Working at 250 deep.

  2. Glitching with move/copy

  3. In this video I set the wall thickness on the window component to 500D. I try and move it in but as this one was move/copied from the original it glitches. I copy and paste it, and that seems to sort it.

  4. And a final video of it not working for love nor money at 200D.

My guess is that these glitches will be ironed out with future releases - just thought the guys in the development team might want to know about them. And in case you guys are reading this - thanks so much for a great additional to the Skp tool kit!

1 Like

Other option with an auxiliary group:




Another option:
I put the snap inside an auxiliary nested group (not at the center to avoid center point snaping) and you don’t see the blue snap but you can move snaping to it.



1 Like

Nice one rtches. That works. As soon as the Skp Team make snaps in nested components more visible that’ll be the solution I’ll use. In the meantime I’ve refined the “snap balance” component I mention above to ensure it is comfortably deeper than the window that it is balancing, and it seems to be behaving without glitches now. Thanks to you and TysonK for helping crack this one :mechanical_arm: