Snap will not recognize corners, midpoints, or reference points, only edges


#1

Snap will not recognize corners, midpoints, or reference points, only edges
The courser only shows a purple X. the red and green dots are not showing and I do not know why.

Suggestions?


#2

This issue is also File specific. It does not occur in a new file.


#3

Can you post the skp that has the issue here ? (Use GTRL+G or the Upload button in the Edit post toolbar.)


#4

no I cannot release the file to the interwebs


#5

Have you tried to copy the geometry into a new file?


#6

Yes that does resolve the issue, But does not shed light on what happened


#7

OH you have an AMD/ATI FirePro V4800 ?

You could try to uncheck Fast feedback in the OpenGL panel of Preferences dialog.
If that does not work, try unchecking Use hardware acceleration.

AMD graphics have been having OpenGL issues. (Old FirePro cards especially.)
See:
http://forums.sketchup.com/t/amd-gpu-crash-on-export-or-save/15560
http://forums.sketchup.com/t/sketchup-pro-2015-crashes-when-saving/10026/7


#8

unchecking fast feedback does nothing. And yes I did reset sketchup


#9

It’s rare, but there are cases with defect files. Since you are not allowed to share the file, we can’t have a closer look…


#10

Are the inference text tooltips appearing at all for the dots that do not show ?


#11

no clue what that is. But No there are no words stating middle, or intersection. Only purple X


#12

That is what I meant. So the inference engine does not think the cursor is near the midpoint, etc.

Do you have a High DPI Display ? There are some current issues with the cursor aperture (working box) on very high resolution displays.


#13

The latest FirePro driver is [Catalyst Pro v14.502.1019] (http://support.amd.com/en-us/download/workstation?os=Windows%207%20-%2064#catalyst-pro)

The latest listed as certified for Trimble SketchUp Pro is v13.352.1009


#14

FIGURED IT OUT!!!

The error occurs you turn off edges in the display styles. It would only recognize the first corner. After that it was a sloppy purple X.

To fix it I simply turned edges on.

BOOM!!


#15

Nice you find and shared the solution!
(It sounds plausible that there are no inferences for edges that aren’t there :wink: Maybe an image in the first post would have shortened the search…)


#16

With displaying edges Off you won’t have any inferencing to edges either. This was misleading info.


#17

But I am glad you found the answer. I still think it’s a bit weird to suppress inferencing according to styles.

Anyone else enjoy this behavior ?


#18

The reason snap etc may not be working is because the component is glued. Right click and select unglue
Daniel