Slow performance in new Dell XPS (Intel i7-6700HQ) laptop


#1

Hello all,

I’m fairly experience user and I’ve using sketchup for a long time with many difference laptops and desktops. I have recently bought a new laptop, Dell xps with infinity edge.

Sketchup is running very slow, when copy and paste, when changing styles and layout when copy and paste and adding images. I don’t know if it a problem of the laptop or a problem from the installation or maybe something else. I’m attaching a screen grab os the espec.

.

I’ll really appreciate some ideas on what to do.

Thanks


#2

Not so good at Spanish, but I don’t see the model of your graphics card which is quite important for SketchUp.

Under your profile, you have GIGABYTE R9 270 X 2GDDR5 listed. If that is in your laptop, you may face some issues since it is a Radeon card.


#3

The laptop model has either Intel integrated graphics or an additional Nvidia Geforce GTX 960 M card. The latter should be quite good at running SketchUp. If you have that, check that your graphics driver is up to date (I prefer drivers directly from Nvidia) and that SketchUp is set to use the Nvidia card in the 3D application settings of the Nvidia control panel.

Anssi


#4

ensure that SketchUp is running on the dedicated nVidia GeForce GTX 960M and not on the integrated intel HD 530, use the nVidia control panel for doing this.

The XPS 15 9550 series had some issues with the BIOS, ensure via the Dell System Detect support tool or their website that the latest BIOS version is installed.

And keep in mind too, that running on battery decreases the power consumption by throttling the CPU/GPU, connect to AC for getting the max. performance.


#5

If you will be copy and pasting geometry, try grouping this geometry, and then copying the group.

Also assign groups and components to use some other layer than “Layer0”. There have been reports of drastic slowdowns with groups on “Layer0”.

Model in Xray mode with textures off. And use one of the “Fast Styles” until modeling is done.


#6

Did the above help you fix the problem? The xps15 with the 960 gfx crd should be a fast laptop. I’m thinking about buying the same so I’m interested to know.


#7

I have a non-Dell with the same i7-6700HQ processor and Nvidia GeForce GTX 960M graphics card and it runs sketchup fine.
Just make sure you set sketchup to use the 960m card in the Nvidia control panel as Anssi mentioned above.


#8

Sorry for such a delay. Last week was hectic. Yes, I did change the preferences for the graphic card, sketchup and layout to used nvidida and energy setting maximum performance. I was using a second monitor not sure if this could interfere. These week I’ll do some more test and do a follow up to find possible reasons.

Thanks


#9

Thanks Dan, I have never came across three layer 0 issue. I’ll keep it in mind and reorganise my model. I’ll post any updates.


#10

SU 16 WAS very slow on my new computer UNTIL i switched off all the background programs. As I didnt know wat they wewe, I used an AVG optimiser. Now SU goes really well.


#11

SU should be opened on the primary monitor.


#12

Did it work for you? I have the same config as yours and my sketchup is just very slow.