Extreme slowness when matching photo


#1

I just got a new Dell XPS 8700, with 500GB SSD, NVIDIA GoForce GTX 745 graphic card and Pentium i7 processor. Running 64-bit Windows 7.

This is supposed to be a rather strong machine.

However, to my amazement, the simplest model in SketchUp 2015 I made, I encountered a problem when matching a photo: extreme slowness! Positioning the red and green direction lines is horribly slow. Can get done, but it feels as if all the memory has been eaten up. When you give up and delete the photo you were meaning to match, the program speeds up, but not fully so, as when orbiting, now you don’t see a full image, but only the linear outline of some components in the model. When I close SketchUp and reopen, the orbiting is OK.

What is going on here?

On another note: with the above mentioned graphic card and the Dell 27" E2715H monitor, I am not able to display straight lines to a satisfactory quality in all directions, as non-aliasing evidently doesn’t produce quality anywhere close to what I had earlier with, for instance, my previous HP EliteBook 8440w laptop connected to an external monitor and the graphic card Graphics Controller Model Quadro FX 380M. The edges in Sketchup don’t look very even. An attempt at nonaliasing has evidently been done, yet the result is nowhere close to perfect. Needless to say, I tried ALL settings combinations both within SketchUp and with the graphic card control panel. Does anyone have an idea how to go about improving this. Could it be that I would need to buy an even better graphic card? What surprises me even more, is that on my old Dell Precision 380 machine, with the very old graphic card Quadro FX 3450/4000 SDI I had quite better quality straight lines displayed…

Any help appreciated. Thanks!!!


Hardware Purchasing Advice For SketchUp & LayOut [wiki]
#2

Also, I notice, when just “intesecting with selection”, SketchUp is incredibly slow. It gets the intersection done, but the wait time is too long. I used to have it light fast on my old computer (it was also SketchUp 2014, or Sketchup 8 - is the new SketchUp 2015 known to be buggy?).


#3

What happens when you adjust the OpenGL settings – In SketchUp Preferences.

GeForce GTX model 745 doesn’t appear on Nvidia’s GeForce Website. . . Maybe a custom build for DELL (?),… and if so I wonder what changes were made vs. closest namesake GTX 750.

Might be worth contacting Dell to see if there’s something necessary on your end to get maximum support for the OpenGL standard which SketchUp is making heavy use of.

Take this as light hearted guessing on my end. Others on this forum have more expertise in Graphic Cards than I do. But a strong support of Open GL is always desirable.


#4

Here’s the link to the NVIDIA’s GTX 745:
http://www.geforce.com/hardware/desktop-gpus/geforce-gtx-745-oem

It is very much a known GeForce model.

Further, I did try to get help from Dell, but it lead nowhere for now. The representative I spoke with is trying to “escalate” the issue internally, but it seems to be taking a long time.

When it comes to OpenGL settings, well, I am using exactly the same settings as I was using on my previous machines.

This PC has a ton of RAM, SSD, supposedly great graphic card.

This SketchUp slowness when intersecting (all within a rather small model) is very surprising to me.


#5

The Dell XPS 8700 is primarily a gaming rig based on its specifications, while your former system, the Dell Precision, was designed to be used as a workstation for CAD and graphics use. Unfortunately, this may account for the noticeable difference in performance. It is often discovered that computers for gaming purposes do not function as well as systems designed specifically to accommodate graphic production.


#6

It’s not about the same settings as you had on your previous machine. That will hold true for the same system specs… but things are different now, and hopefully for the better.

I wouldn’t troubleshoot this issue by holding onto the idea that the same settings should still work on your new machine… they might not in this case.

There are not a lot of options to mess with RE: SketchUp and it’s use of Open GL settings… It’s going to come down to whether or not your card is configured to take advantage of such things. and if it’s not, the fix is to get a card which does. . . I don’t believe that you can just install a separate set of drivers to fix such things.

I like what @jvleearchitects said.

CAD vs. Raster require a bit of favoritism. A system that’s great for one, doesn’t work equally well for the other. You have to hedge your bets on which side is your priority. This even holds true with printers where some handle line work much better than others… and I know this isn’t about printers… I’m just trying to suggest that the CAD vs. Graphics dilemma is wide spread, and not easily overcome (in a variety of areas).


#7

Holy cow!!!

Does that mean that I just bought an $1800 computer which doesn’t work well with SketchUp, and nothing can be done to improve it as is?

How could’ve I known that this Dell was not good for architectural applications?

I heard what you both said, but it still comes as a shock to me that the enormous slowness of as simple operation as “intersecting with selection” in SketchUp can be due to the fact that an Intel i7 machine with 12GB RAM is not meant for applications such as SketchUp?!? I can understand (sort of) that the quality of display of graphic details may suffer on a machine that is primarily meant for gaming, but that “photo matching” in SketchUp can still be so enormously slow, just because a PC is meant for gaming, come on?!??? Really?


#8

Nobody’s saying this, at the very worst it’s a graphics card issue. So you’re not wasting money in realm of $1800.

Having a SSD is good, and the i7 series is also great. Don’t feel bad just yet.


#9

Do you here mean just that the graphic card is wrong choice? Processors are processors, there aren’t different types of Intel i7 for different purposes?


#10

As I said, I can understand the difference in display quality.
But “matching photos” or “intersection with selection” is pure analytical geometry, i.e. math number crunching. I’m not able to connect that stuff to a graphic card, right?


#11

The previous forum had many posts which specifically addressed graphic computer capabilities versus gaming systems. And frankly, I’m not entirely sure if the issue has ever been finally resolved. Processors differ from manufacturer to manufacturer and may vary in different model units from the same company as well. The processor does have an impact on performance and functionality, however you should be able to find a palatable approach to your dilemma without the need to replace your hardware.

Here are a few links to point you in a direction to get more information on the subject.


http://help.sketchup.com/en/article/36235

You may also want to read this…(not suggesting you want to buy another system, but this thread features a discussion on what systems are better for SketchUp use).


#12

Thanks for your response and for the links.

Generic ‘economics’ when using SU is not the problem here. My setup cannot process even a smallish model if I “intersect with selection”. It gets locked into what seems as an infinite loop…

The GeForce GTX 745 card, which I have, has these specifications:

http://www.geforce.com/hardware/desktop-gpus/geforce-gtx-745-oem/specifications

It says that it supports OpenGL 4.4.

Is there a way to know if that is the case for sure?

If it comes to it that I need to buy a new graphics card, what would be your suggestion (as good for SketchUp)?


#13

My expertise is in the field of architecture…I’m no expert on graphics cards; I just know there are many kinds. I understand that the GeForce display adapters are oriented to gaming as stated before. The specs seem to support that assumption. My experience has taught me that the Quadro display adapter series, also from nVidia, appear to be targeted at the professional design and engineering market, so my initial suggestion is to recommend a graphics card from the Quadro series. Before investing additional capital, take the time to research the various display adapter products and obtain informed opinions from knowledgeable resources. I would even recommend talking to Dell technical and/or sales representatives to discuss the specific issues related to your current setup.

Depending on the circumstances of your recent purchase, it’s possible that an alternative resolution could be provided by the computer manufacturer, but you won’t know if you don’t ask. On a somewhat unrelated note, Dell provided a full replacement system to me after experiencing an irreparable loss due to the system’s malfunction.
jvl


#14

Thanks.
Well, I was hoping to get expert advice here. So, if anyone else can jump on with some useful advice on graphic cards for SketchUp, please do!

I’d need to learn if I will need to replace the GeForce GTX 745 (4GB) with something else. Its spec says it supports OpenGL 4.4. Yet, I have the above mentioned problems.


#15

I would guess that you have quite enough card for SketchUp. Do check that you are using a recent driver, preferably directly from Nvidia. Are you using a very high resolution display? Another user in a recent thread had issues when running SketchUp on a system with two high-resolution monitors, but he had a 2GB card. My recently scrapped old luggable ran SketchUp 8 decently with a 64 megabyte card.

After a glance at the Dell specs I am not sure whether your computer also includes an Intel graphics processor either on the motherboard or integrated into your CPU. If there is one, you should make sure in the 3D application settings in the Nvidia control panel that SketchUp is set to use the Nvidia card. Also, features like Antialiasing should be set to application controlled.

If the card settings are set correctly, SketchUp should present you with a couple of antialiasing options in the Window meny>Preferences>OpenGL dialog. I don’t mind the jaggies and prefer to set mine to 0x for speed, but it is a personal preference. I use other methods to get nice lines into the images I output.

What do you mean with a small model? What shows in ModelInfo>Statistics when you set it to include components?

Are you performing the intersect in a photomatch view? Photomatch views are somewhat special, and I think that they might not be using hardware acceleration. For instance, they preserve the full resolution of your background image.

Just thoughts

Anssi


#16

I am using the most recent driver.
It is directly from nVidia, of course.

The display resolution is 1920x1080 (native) on a 27" Dell monitor.

The cars should have 4GB.

How do I determine if the “computer also includes an Intel graphics processor either on the motherboard or integrated into your CPU”?

I did set all the antialiasing features to “Application controlled”.

I am not performing the intersect in the photomatch view.
For instance, when I want to intersect a simple plain with the existing model, the SU freezes (perhaps hours later it would come back, I never could wait so long).

On my old machine(s) I used to work with incomparably larger SU models, and never a glitch. This is just a beginning of a bathroom model (can send it to you if you’d like to check intersection on your machine!). The Statistics are: Edges: 139721, Faces: 92329, all else trivial.

When trying to match photo, just positioning the green and red lines takes forever, as slow as can be. After deleting the photo (i.e. after giving up), orbiting no more displays full image, just outlines of some components.


#17

In my books anything that approaches 100 000 faces is large - a completed bathroom design I did once had about a tenth of the geometry in your model, and the file was about 650 Kb.

You can check the available graphics systems in the Nvidia 3D application settings. If there are other options than Auto-select and your Nvidia card, you should set it to point explicitly to the Nvidia. Windows has a tendency to (totally unnecessary in a desktop) select integrated graphics to save power.

In a MatchPhoto view, the imported photo will cover up your model unless you go to Window menu>Styles>Edit>Modeling settings and uncheck “Foreground photo” or make it more transparent with the slider control. Matching the axes with the photo is much smoother if you turn off the model display while doing it. Is the photo you are matching to very large? It might help to reduce it to something near your screen resolution.

BTW, Funny, I just noticed that the Nvidia control panel still refers to “Google SketchUp”. I must see if it is the same with computers that have never had older versions installed…

Anssi


#18

Ha!
Apparently nVidia never read the memo.
My current pair of SCSI HDDs have never seen SU 8


#19

The truth be told, I downloaded the tub, faucets and undermount sinks from the 3D database. These represent 90%+ of my model size. File size is, grantedly, 22Mb.

I now realize that “intersect with selection” might have indeed been computationally too demanding. Perhaps I was expecting the new PC to be able to crunch such things too (not sure that the old one would’ve done such a task easy either).

The photo I tried to match was 2.2Mb. In my previous models (of the file size 50Mb+) on the old computer, I was able to match many such photos. Photo matching was never ultra-fast, but this now, with a PC that was supposed to be much stronger, is unusable.

These are my card settings:


#20

Anssi, many thanks!
Indeed, deselecting “Model” when positioning the lines made it much faster.