Skewed lines, shattered faces, and hairy circles. What's going on here?


#1

I’m still fairly new to SU and CAD in general. I started drawing an adapter to size from scratch in SU with no importing or exporting involved. This part being about to fit within a 4" cube, resulted in a few skewed lines when intersecting circles and faces being deleted upon using the “follow me” tool. I found that scaling up by x5, x10, and x100 would yield better results. I’ve jumped back and forth between actual size and the above sizes in order to complete some of the trickier shapes, (radiused fillets around circles), as some tasks would not work correctly until I scaled up, and then back down. Every bore in the piece needs to countersunk, and some of the bevels will have skewed "shoulders which I can’t seem to avoid.

I came very close to completing the part, but one face decided to “shatter”. The more I tried to correct it, the worse it got. I removed every tiny sliver, which subsequently removed all of the side faces, too. Some of the radii on the sides became straight again…?? I’ve torn most of the model down and scaled to x1000 in the hopes that it would help. Same thing. I’m beginning to think I need to start all over at x1000 from the start. I’ve found a couple helpful posts that seem to point to drawing in a much larger scale from the begging as a solution. I did reveal all the hidden geometry and cleared out the funky stuff, but that didn’t do me any good.

One other thing that’s a bit troublesome is circles becoming “hairy”, at times. Either connecting two circles via one line, removing or adding a non-intersecting line at the other end of the piece, or adding a face which connects to the circle(s). It appears as though the segments elongate and overlap, creating a blot or large node at each vertex. I’ve been drawing all my circles with 100 sides which has been working out great. They’re all smooth until one of the described actions. I have some pictures with examples. I’d like to confirm if this is a scaling and/or graphics card problem. Looking forward to your suggestions!


#2

Shattered face and some hairy circles. Sometimes I can avoid the hairy circle by undoing the operation and coming at it from a different order of operations.


#3

Started deleting the shattered face and the once radiused edge became a straight line.

I’ve had this happen a few times. Try pulling a circle up or down to create a chamfer, and get these shoulders. If I delete the lines of the shoulders, it get holes and find that the chamfer face is shattered.


#4

Enable Hidden Geometry from the View menu. Delete the hairy stuff now. I have Edit > Select None as a keyboard shortcut so geometry isn’t inadvertently left as selected when switching to another modeling step. Hidden Geometry also deserves a keyboard shortcut. This happens if drawing gets a little sloppy.

The one shimmering circle looks like z-fighting - 2 faces sharing the same plane. Is the circle a grouped face resting on another face?

Regarding the part with the offset rings, it looks like the inner circle was moved down (auto-folded) and the faces triangulated awkwardly. Again, enabling Hidden Geometry will show what’s happening. Sometimes SU doesn’t fold things as desired. Either erase and manually re-stitch the faces or enable the Sandbox extension from Window > Preferences > Extensions, and use the Flip Edges tool (from the Tools menu or Sandbox toolbar) if faces are triangulated. Sometimes I will pre-draw some lines to encourage auto-folding to work as expected.

Your circles and curves have a lot of short segments.


#5

Generally, attempting to fix a poorly made model is a waste of time and effort.
Treat it as a learning experience.
The next version will be better as will the one after that.

On the contrary, modeling highly segmented circles is a large part of the problem.

• Circle orientation is an important aspect of creating a clean model. As segmentation increases; circle segment orientation becomes increasingly difficult to detect.

• Given SketchUp’s limitations when creating tiny new geometry; modeling small diameter high segment circles often leads to missing edges, faces or geometry slightly off axis.

Certain operations can fail when modeling tiny high-poly geometry.
Model BIG from beginning to end and then scale down when finished.

The black blobs are an adjustable rendering Style called Endpoints.

When Endpoints are enabled, the two endpoints of Edge, Arc and Curve entities are rendered as dots.
When a Circle, Arc or Curve entity is exploded, it becomes a series of contiguous Edges. (with endpoints)

Sometimes exploding curved entities isn’t what you want, yet it would be helpful to see vertices.
A plugin like Add Vertex+ marks all vertices with Guide Points which can be deleted via the Edit menu.


#6

The shimmering circles will be without a face, but once a connect everything to make a face on the same plane as the circle, it makes that appearance and I can no longer select the entire circle’s circumference, but have to select each of the 100 sides individually. I’ve been able to avoid it entirely while being scaled up by x1000 from the start until just now. I’ll post what happened so I can get it figured out.

I ran hidden geometry and removed all lines that did not pertain to my model’s actual structure. Made no difference at all. I started over at x1000 and have had a clean model all the way.


#7

Lesson learned, it is. Started over with all measurements being scaled x1000. Those dots showing up at vertices are what I’d like to prevent, particularly on the circles. It becomes impossible to select the entire circle’s circumference, (unless there’s a trick I haven’t learned yet).

My new and improved model has been near flawless - until one of the last operations (still scaled at x1000 from the begging).

As seen, I select this center bore circumference so that I can pull down to create a chamfered edge. The picture I’m posting doesn’t show my cursor, but it is on the highlighted circumference with the “move” tool and the down arrow key depressed to constrain movement to the blue axis.

I pull the circle down, and once I click to set it, the dots at the vertices show up again with a couple gaps/missing segments. You can also see some strange lighting showing at those gaps. I’ll try redrawing those circles using fewer segments to see if it helps. The diameter of that highlighted circle is 632". No segment should be anywhere near 1mm.

Hidden geometry


#8

I have always found circle segmentation that is divisible by 8 to be far more successful in SU geometry…

other people stick to divisible by 4 or 12, but the concept is to retain on axes ‘cardinal points’ which make modifications less error prone…

john


#9

I redrew those circles involved in the chamfer with 50 sides which worked out. I was curious if there was a magic number. I then drew the o-ring recess using a circle with 50 sides as the path to follow. This worked without skewing any geometry, but once again made all the dots at vertices. Not a huge deal as it needs no further modification, but I am going to taking this to the local machine shop to be made on their CNC mill. I don’t know how smooth the appearance of the circles needs to be. Less than 100 sides looks choppy, but there’s surely a way to round out a 48-sided circle after its been drawn if need be.


#10

The dots are an edge style called endpoints, as Geo indicated above. You either enabled it or it was preset in the template you choose. The quickest was to disable it, go to View > Edge Style and disable. You can further adjust the size of the endpoints through the Style browser, Window > Styles > Edit > Edge.

Endpoints are a design style which can double as a drawing aid and even a diagnostic tool. It can be a drawing aid as it IDs the end points of edges. And in your case, a it tells you the Follow Me tool step broke up the polyline path into it’s individual segments.


#11

As a quick tip: if you want to select all lines that go round the circle (if they have been exploded), double click on the circle face to select the face and all of it’a bounding edges, then hold [shift] and click on the face to remove that from the selection,

If you have a “hole” in the circle, then you need to fill it in so that the hole section is solid (you can always delete the surface again); then you can click on the hole surface (while holding [shift]) to add it to the selection, and double click it again (while holding [shift]) to remove it and the inner edges from the selection. You should now be left with only the outside edges of the circle selected.

Note; be careful not to triple click when doing this - you will selects all surfaces attached to the target one.
Note: If you double click on a line rather than a surface, it will select the line and all surfaces that it’s an edge for.