Sketchy styles , transparent images


#1

Hi, everytime I change to a sketchy style the images of people, which are png´s appear transparent.
I do want transparencies like for window, but the image of the person should not be transparent.
see enclosed sample:


#2

Try turning off Use Hardware Acceleration under Window>Preferences>OpenGL.

You might also check to see if there are driver updates for the GPU.


#3

Thank you but that wasnt it. I had this problem on different machines.

when I use the standard sketchup styles the images appear solid. when I use any of the sketchy styles the lines of objects in the background shine through. is there any other setting I am missing?


#4

Can you share one of the images?


#5

thats the same model in architectural default style. The lines of the objects behind the people are not visible.


#6

Sketchy edges are PNG raster images that SketchUp lays over the vector lines you’ve drawn. Raster and vector get handled differently by the graphics processor.


#7

is there a way around it to have the sketchy style but lines behind the people? many thanks


#8

When I’ve see this sort of thing before, it’s always been related to the GPU. The fix has usually been to turn off Hardware Acceleration and in some case updating the drivers for the GPU.

I’ll ask again, could you share one of the people images? I’ll try it on my computer.


#9

Notwithstanding their visibility, isn’t it slightly odd that two of the “people” are photos and one is a sketchy cartoon? Sort of like “Who Killed Roger Rabbit?”

-Gully


#10

3d design.skp (1.4 MB)


#11

never mind the composition… I just tried out different imported objects but it happens on both types.


#12

Okay, just sayin’.

I get the same results even when I add my own transparent png.

-Gully


#13

for some reason this one is solid… so must depend on the image…


#14

I was about to say the same thing. I get the transparent people with your image and a sketchy style but I don’t get it with other images.


#15

Have you tried setting the transparency quality to “Nicer” in Window menu>Styles>Edit>Face settings. PNG image transparency tends to do this, especially with the “Faster” setting.

Anssi


#16

yes but thats not the problem.

I think it has something to do wether the image is acutally cut out in sketchup. i.e. you need to freehand cut around
the image inside sketchup. put not sure what the acutal procedure is.

if I click on the the last image a number of times until I get to the actual image seleceted, only the body is selected.

the first images that are transparent are not cut out and the whole rectangle is selected.