How to fix overlapping PNG textures?

As you can see in the picture, tree no.2 should be in front of the trees no.1, no.3 and no.4. How to fix that?

Sketchup is going to have trouble with overlapping polygons containing semi-transparent textures because I believe the only way to properly draw this would be with a very CPU-intensive z-sort.

I’d fix this by removing all transparency from the underlying PNGs, then trim the tree geometry to match. The effect won’t be as nice, but the result will be properly sorted.

Try adjusting the Transparency Quality of your current style.
https://help.sketchup.com/en/article/3000109

2 Likes

Transparency Quality actually fixed the primary problem, thanks, but then I got this. I can’t remember I had a problem with those white lines in Su 2016. (pic related)

What is your graphic card? And have you kept your graphic card drivers up to date?

GTX 1060 6GB with updated drivers but the problem is still there. Should I change settings in Nvidia Control Panel?

Antialiasing and Anisotopic Filtering should be set to Application controlled.

I tried everything but without success.

How can I get rid of those white lines? Anybody?

How was the image made? It seems like it may have been premultiplied white. If that’s the case you would need to go back to the master image and export it a different way.

Or is what you showed geometry?

Is that a direct image export from SketchUp? If so, change the back face color to black or dark gray and see if that helps.

If it does look ok on screen, and you only get the artifacts when exporting PNG, try turning off antialiasing in the PNG export options, and export the image at a much larger size. Then open that in any program that can resize an image, and resize it back to the correct size.

It may fix the white issue, and will give a lot better antialiasing than you get straight from SketchUp.

This image is just a screenshot and my problem is how its looks as a 3D model after I set textures from “faster” to “nicer” in style menu. I don’t need JEPG/PNG exported files (which don’t have that problem btw), I need a good looking 3D model in Sketchup.

All back faces are textured so that’s not a problem.

Whyare back faces textured? They shouldn’t be exposed.

Is there any white in the texture image? It could be an issue with uv wrapping, which Sketchup doesn’t handle very well. If so, paint the white areas in the texture black, and have another go.

@DaveR, texturing back faces does improve the display quality when there is fine detail in a model, Sketchup, (actually OpenGL) tends to leak the back colour through due to precision issues in the z-buffer. But this is mainly a Sketchup thing because Sketchup draws nil as a colour and doesn’t simply not draw the triangle.

I know that the back color leaks through. I find it easier and faster to make the back face color dark which is why I suggested it.

Only back faces are not textured (except some components like blinds and window frames) but even if I back faces turn black problem is still there. My AA is x16 so that’s also not a problem.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.