Sketchup 2019 Pro png textureing issue

I’m using Photoshop to knockout model pictures and put in sketchup.

It was as usual, till today, I found out there’s some noise on my transparent objects in sketchup, looks like glasses’ scratch.
image
To make sure white background is removed, I added another black background under the diffuse layer in photoshop, as you can see, there’s nothing.
https://imgur.com/8tFPC0r

Another issue is, one png texture would block other transparent objects like this.
https://imgur.com/5ow7M4b
I’m not sure which part went wrong, any help would be great, thx all!

Try going to ‘Styles’ panel, then ‘Face’ Then set transparency settings to ‘Nicer’.

1 Like

I’ll try your way! Great thanks.