Sketchy Lines Don't Work in LayOut

It appears that a “sketchy” line type does not properly get handled in LayOut.

In SU

In LO

What rendering mode in LayOut?

It works for me.

It was in Hybrid. I changed to Raster, and it corrected itself.

Por que? There seemed to be nothing “vectorish” in the sketch elevation. I guess if it is in Hybrid mode and sees a line it treats it as a line, whereas the “sketchy” line types are more of an image perhaps and less a line and so they render better in Raster mode.

Dave, thanks for your ever-ready-to-help persona.

Hybrid renders the edges as vector lines. Sketchy edges are created in SketchUp by overlaying .png (raster) images of strokes over the edges in the model. If you want the sketchy edges to be displayed in LayOut you have to leave the rendering to Raster.

You might want to explore Style Builder a bit so you have a better understanding of how the sketchy styles work.

Note: This is not a bug as you indicate.

Correct - NOT a bug.

I liked your description / explanation of how SU/LO overlay an EDGE with the image - otherwise the edge gets rendered as a vector. Makes perfect sense.

Thanks again.

1 Like

Maybe edit the “bug” keyword out of the title?

The overlay thing is happening in SketchUp. It’s helpful to understand that a sketchy style can have up to 7 different stroke lengths and up to 10 different strokes of each length. Most have far from the maximums, though. When I create styles for my own use I do use the max numbers. One of the implications of this is if edges are shorter than the shortest stroke length in the style, the edges won’t be displayed. For example, note the leg on the left in this view of my model. In that one I have exploded the curves. The edge segments in the curves are shorter than the shortest stroke so they aren’t rendered.

Eneroth Autoweld is an excellent tool to get around that problem.

Done. Bug gone.

I have noticed that sketchy lines cause problems with dashed line types. Is that a shortness issue as well?

1 Like

No. it’s more a conflict between dashes and the sketchy styles. Dashes are a little like the Sketchy styles in that the edges aren’t really dashed. It’s just an optical delusion. If you want dashed sketchy edges, you can divide an edge and then hide alternate segments.

Optical delusion … I like that.

1 Like

Would I be correct in saying that dashed lines as “created” by the “Back Edges” button (Display the model with back edges dashed) will not show back edges in LO if the model is rendered as Vector?

For example, if you are looking at the front side of a board with a groove lengthwise on the back and showing in SketchUp as dashed lines because of Back Edges Dashed button is selected, then, when viewed in LayOut as vector rendered, will not show the dashed back edges. They will show if it is raster rendered.

Yes. To get the same effect in Vector in LayOut you can overlay two viewports. One in a hidden lines style, and one in wireframe, and set the latter to use dashed lines.

As @Anssi indicated, you are correct. Like guidelines, back edges are a raster thing so not rendered in Vector rendering. Stacking viewports works very nicely and easily in LayOut with dashes applied to the tag and a wireframe style applied to one of those viewports. This is a good way to show hidden details. That’s how these viewports were handled.

Anssi and Dave,

I’m struggling. Maybe it’s too hot here and smoky - not cool, colorful Colorado right now.
I made 2 scenes, one wireframe, one hidden line. (BTW, the hidden line version in SU looks pretty much like I’d like it to in LO.)

I made 2 layers in LO, one Vector, one Raster and put the wireframe scene on the Vector layer and the hidden line scene on the Raster layer. I am not sure how to accomplish Anssi’s comment about “set the latter to use dashed lines” - in SU or LO? Does that mean everything I want to show as hidden needs to be on a tag that uses dashes?

Also, if I put the vector window on top, then no hidden lines show. If I put the raster window on top then I lose the effect of putting nice, clean linework on top for dimensioning, etc. ala Nick Sonder.

And the final conundrum comes with why the holes in the middle piece aren’t showing as hidden or dashed.

I know I am doing something wrong, or at least out of sequence or out of order. Any help short of a 2x4 is appreciated.

Test Jamb Pieces.layout (111.4 KB)
Test Jamb Pieces.skp (74.3 KB)

There was nothing about rendering one viewport as Raster while the other is Vector. Render them both as Vector but change the style for one to Wireframe and enable the dashes.

Here’s a sort of closeup of the stacked viewports.

Here I’ve copied those viewports and cropped them so you can see some of each of them.

Both viewports in the stack use the same scene from SketchUp. No need to make different scenes for each one. I selected the styles for the viewports in the SketchUp Model panel.

FWIW I have created a collectionof styles that I commonly use in LO documents and I access those from LayOut. I also select dashes for tags by viewport only in LayOut. No need to apply dashes in the SketchUp model.

And here’s the LO file.
Test Jamb Pieces.layout (157.7 KB)

And of course you might want to use 2-view or 3-view views of the parts.

And now I’m just screwing around. :slight_smile:

Scale of 1:4 instead of 1:8

You’re cracking me up.

Let me know when you’ve fooled around so more, by which time I presume you will have actually made it, and we’ll arrange for shipping.

1 Like

LOL. I kind of gave up and started watching ships going in and out of the canal in Duluth.

One of the things with that last image, though, is that there are now four viewports, all using the same scene. LO will automatically dimension across the viewports so you can use break lines and cut out sections where there are no details.

Sounds relaxing - perhaps with an aperitif.