SketchUP WebGL error message on some iMacs

Sketchup for Schools has been working fine in our lab. Today, several computers are getting a “Sorry. We encountered a problem with your web browser’s WebGL support” message when trying to open.

These are all running Sierra 10.12.6.

However, they are not all the same computer. All the iMacs that are Intel Core 2 Duo models are getting the error message, those that are i5 processors are not.

They were all working last week

Did you find a fix? had the same issue. Made sure webGL was enabled, tried going incognito. Finally tried Safari. Safari is what worked, although I am not sure why. I would think SketchUp would talk to Chrome easily. It appears to only be a mac issue. A PC user had no issue with it in Chrome.

I had to install Safari 11.0.2 to test ‘SU Free’ on my Core 2 Duo iMac running El Capitan…


Hey, thanks for the tip. I didn’t even know you could use other than
chrome! So my only fix is what you provided - using Safari.

My Mac running Sierra with an 3.06 GHz Intel Core i3 has the same issue. It works in Safari, but I can’t download my models back to the computer with Safari? It appears to work, but no new file is created on my drive anywhere. Any fix for that?

look for files named ‘unknown’ and maybe 1, 2, 3, etc… in Downloads…

there is a Safari issue they are looking into…

rename the file and they work…


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.