SketchUp Web on iPad, Orbit tools not working

When I am using SketchUp web, the Orbit tools seem to do nothing. I can use the pencil tools, and anything that requires just a click. The orbit tools seem to be frozen, anything that seems to require a swipe across the screen is not working.

The push/pull tool seems hit and miss, but not working either. Comes across as a delay from the drag input, rather than a straight not working.

It is working on my iPhone and my Laptop with no issues. Have tried on both Chrome and Safari. But I have tried on various iPads, pro and older versions, and the same issue seems to appear on all iPad attempts.

I have a class of students with the same issue, all on iPads.

Any ideas ?

Well, SU Web is not made for iPads. I can “make” it work on my iPad Pro but only if I use a BT Mouse but still no where as well as say on a PC/Mac web. On the flip side it works great on my daughter’s Chromebook.

1 Like

What model iPad do you have, and what version of iOS are they running?

iPad 6th Generation and OS 14.1

It doesnt not seem to matter, my students with older ipads at home had the same issue.

We used it in class for a whole unit, March - April with zero issues, I have a whole bank of resources, made on the iPad version. It works on my iPhone ok, so I dont get why the iPad version is an issue.

To be clear, yes I can “use” it but I have used SU since v3 and I am used to the Desktop version and to me it’s not as “usable”. It’s not as user friendly nor is it as robust. If I was a teacher with my experience I’d rather them use a Chromebook and have a bit more control/usability of the app, imo.
I hope you get it sorted. SU is a GREAT tool for students.

We have to use the tools that we have, all our students have IPads, so its either use SketchUP Web on IPad, or not at all :stuck_out_tongue:


It’s amazing if you can actually accomplish anything with SU on an iPad. Being able to hover the cursor over things is crucial to many tasks, and that’s impossible on an iPad with it’s native touch interface.

1 Like

It’s just for young students starting the 3D modeling journey. I have managed an entire unit from it, so it’s obviously not that bad. Less passive aggressive comments and some actual help would be nice :slight_smile:

I had the same question as @RTCool, how are you hovering to use inferencing. Are the students using mice connected to the iPads? I had thought Sketchup was unusable on iPad. Not trying to be passive aggressive, just genuinely surprised and curious how you are gettin on. I don’t think there is much help available as it’s just not designed to run on an iPad.

Well, it does appear on my iPad G6 with both Apple Pencil and with a finger, clicking on Orbit or any other navigation icon doesn’t do anything as far as I can tell. I don’t see why that aspect couldn’t work. I don’t have any user advice how to get around that. Only someone on the SketchUp team can fix it.

Thank you for checking RT, at least now I know it´s not just me. It´s strange because it was working in May/June with no issues. They must have changed something on the iPad side or on the SketchUp side.

Hi I’m the same I’ve been using sketch up on iPad with the Apple Pencil for the last year and only in the last 6 weeks has it stoped working. I had this problem before and i just had to toggle of desktop websites. This time it has not worked. I think its something apple has done because it works on an android tablet i have . It’s a pity because it was working really well.