SketchUp Viewer for Mobile Viewing Augmented Reality Models

I’m confused about how to use ‘SketchUp Viewer for Mobile’ to view SketchUp models in Augmented Reality (AR).


  • macOS: 10.15.7.
  • SketchUp: Pro 22.0.353.
  • iOS: 15.5.
  • iPad: SketchUp Viewer for Mobile: 5.5.1 (1766).
  • iPhone: SketchUp Viewer for Mobile: 6.0.5 (1864).

I was able to quickly/easily save my SketchUp file (SKP) in SketchUp Pro (macOS) and publish it to Trimble Connect. I was able to quickly/easily access and open my SKP file in SketchUp Viewer (iOS) via Trimble Connect.

Issue 1: AR Tools

Incorrect AR Tools

Based on the SketchUp article about how to view models in AR with SketchUp Viewer for Mobile (Viewing Your Models in Augmented Reality | SketchUp Help), there are supposed to be tools (in a vertical left sidebar) for: Move, Scale, Rotate and Anchor.

However, when I open the the model in AR the only tools I see (in a horizontal bottom bar) are: Reset Tracking, Hide/Show Mesh, Reset Scale, 1:1.

Q: did these new AR tools replace the old AR tools or are the old AR tools still available, just hidden?
A: ???

If these new AR tools are all that is available currently, they seem to be MUCH less useful (to the point of almost being useless).

AR Model Placement

When the model opens in AR nothing happens? If I tap the ‘Hide/Show Mesh’, after a several second delay the mesh does eventually show up. And… if I wait another several seconds, I can see a small version of the model show up. However, the scale is wrong (way too small) and I have no idea what was used to determine its position (X,Y and Z) and rotation?


I can tap the ‘1:1’ button to get the scale correct, but I still have no idea how to get the position and rotation correct? Through experimentation I see that I can ‘pinch-zoom’ works for scaling, but that method is very inaccurate and was already accomplished with the ‘1:1’ button.


I found that ‘sometimes’ I can top/hold to move the model, but I don’t think I’ve figured out exactly how to do that, because I can’t get it to work all the time. When I do get it to work, I find that I can move as far as my finger can go across the screen, but after I reach the edge, the model ‘drops’. If I try to tap/drag again, the model starts from the position it STARTED at, not the position I dropped it?


I have not found a way through any finger combination to rotate the model. If the model placed incorrectly rotated, it stays that way until I close the model and open it again, hoping that it will orient rotation correctly.

Old AR Tools

ALL of these things appeared to have been solved with the ‘Old AR Tools’: Move, Scale, Rotate, Anchor. Perfect! EXACTLY the tools I would want and expect with an AR experience. What happened to them? Is there some way for me to access them that I’m not seeing? I do not see anything in the left except for an ‘X’ button to close the AR experience?

Any help about how to use SketchUp Viewer for Mobile for AR would be greatly appreciated. Thanks!

Issue 2: iPad but not iPhone

When I open the SKP file on my iPad (in SketchUp Viewer for Mobile), I see the tool for AR, but when I open the same file in the same app on iPhone, the AR tool is missing? Why would that be?
UPDATE: this issue was resolved in subsequent posts.

1 Like

Check this thread:

For access to AR on an iphone, you need to be signed in with the email address that has the subscription plan.

Thanks for the quick response and the link to the other topic Mike. I will look at that and see if that helps.

iPhone AR: I was signed into the exact same email address. I just didn’t see the AR tool because of the smaller screen space. Once I expanded the correct tool set, I was able to find it. Thanks!

@MikeWayzovski a subscription is not required in order to use AR when using the iOS app, on either an iPad or iPhone.

@AjMwd thanks very much for your feedback about the AR functionality. The following gestures are available when attempting to position a model: 1-finger drag to move, pinch to scale, 2-finger rotate to rotate the model.

To use ARon your iPhone, tap the select tool icon to expand the toolbar, revealing the rest of the tools that are available, including AR.

Apologies for the confusion caused by the out-of-date help center articles that are still showing the previous iteration of the AR viewing capability.

1 Like

@MikeTadros : thanks for the quick response as well.
I took at look at the other topic and did try the recipe you posted there (thanks for doing that!). Unfortunately, I did not get good results.

IMHO, I’m not sure why the old AR tools were removed? It would be one thing if these new AR tools were added but the old AR tools were left in place. As @KeeneArchitecture posted in the other topic, having an Anchor tool is extremely helpful. In fact, the old AR tools were really ideal for AR work: Move, Rotate, Scale, Anchor. Those are like the perfect set of AR tools.

I tried the recipe you recommended. Likely I did something wrong, but I still did not get a good result. And that is also likely part of the point. The new tools seem to rely on the app to make educated guesses and automatically get a relatively acceptable result. Case in point is the last step of the recipe…

  • Hold your iPad at approx eye level, point the iPad in the direction of a corresponding scene, and then tap to activate that scene.

All of that is ‘reasonably close to intent’ type of methodology, in my opinion. “About eye level”, “in the general direction of the scene”. With the old AR tools, I could select and place a specific anchor point in the model on a specific anchor point in the real world scene, scale to 1:1, tweak the rotation, and - done! It was quick, easy and accurate.

With these new AR tools, I’ve been working on getting this right for almost 2 hours and still do not have it correct. Part of that did involve updating iPad and iPhone SketchUp Viewers, looking online to see what happened to the old AR tools, etc. But, the point is that all of that is extra time trying to compensate for the old direct tools which were able to quickly get direct results.

Again, I don’t mind new tools, maybe those are more helpful to different audiences or situations, but please don’t remove what was working (very well).

Case Study: Deck Railing & Pergola

In my case, I modeled a metal deck & stair railing and metal pergola for our existing deck. I wanted to get an idea of what it would look like in the real world, before committing real money to the project.

Even though I…

  • Have the SKP model with the deck railing corner post at the SketchUp origin…
  • Followed the recipe and have a scene with my camera viewpoint at 5’-6" from the patio door of the house…
  • Opened the model in Viewer AR while at “about eye level”, “in the general direction of the scene”…

The model ended up incorrectly rotated, about 7 feet above my head. My ‘guess’ is that AR ignored where the SKP model origin was set at and just placed the bottom of the stair railing at the floor of the real scene based on my ‘about eye level, in the general direction of the scene’ action.

While I can rotate now with the two-finger rotate (thanks for that!), I have not found a way to move along the Z-axis to get the model down to the correct height? Using the ‘1-finger drag’ to move yields some helpful results horizontally, but quickly (accidentally) ends up either scaling or moving the model far away in the distance and does not appear to work in the Z-axis? (is it supposed to?)

Again, IMHO, all of this is more time consuming and less accurate than the old AR tools which allowed me to directly accomplish direct objectives…

  • Anchor the model point to a point in the real world.
  • Scale the model to 1:1.
  • Rotate the model to match the rest of the real world.

I was able to accomplish all of that within a minute or two with the old AR tools. The new AR tools seem much more time consuming and less accurate to get the desired result. Is it just me? Am I missing something?

Thanks for your help.


HI, i have a problem of mobile too, when i open a sketchup file(size 117M) sending from my friend via iphone 13(ios 15.4) and rotate it for a while, the app itself will crush down, and i have try several time. so i change another file (size 87M), and still the same problem.

I agree, I didn’t have to setup scenes before heading to the job site and do a quick AR session. Now, it seems, I have to spend some time in the office before I can use the feature. It used to be so simple.

Good point. In my situation, even with creating a Scene beforehand, I was not able to get the AR to work. It kept having problems with the Z-axis and since the new AR tools there do not seem to have any way to move along the Z-axis, it never lined up. I eventually just abandoned it and looked for other options outside of SketchUp. Disappointing.

I completely agree. It used to be so simple.

Should I presume that with no further response from Trimble that they do not see this as a problem or that even if it is a problem, there are no current plans to do anything about it?

The sad thing about this is that existing functionality was abandoned, replaced by something less functional and less reliable. If Trimble had just added the less functional approach and left the fully functional approach in place instead of removing the fully functional approach, everyone could have benefited.

Those are big files - it may be that you at hitting either IOS memory limit or your devices memory.

I agree, it seems like they needed some field testing for the new features before a commit. I am one to flow with changes but this new implementation of AR causes me to spend time in the office to get ready for a meeting. I used to be able to grab the ipad and run out the door!

These problems still seem to exist. I spent ages messing about yesterday trying to anchor, scale, position etc without any consistent success. There is also a significant lag when pressing the mesh/ grid button. Given this is the only thread I can find and nothing has been posted for 6 months should I assume there’s a fix or workaround that I’m not aware of? Is there a tutorial somewhere?