Sketchup too slow and sluggish - windows 10

I am using sketchup pro 2019 on intel i5, 8 GB RAM DDR and integrated intel HD graphics 4600 which is fine for casual rendering and related tasks. I am modeling a booth for tradeshow in sketchup and everything seemed to work fine at start. I modeled 3 tables, 8"x3" size boxes on tables and it was working well. Now I want to add some medical instruments that should be placed in boxes. I have modeled them in fusion 360 and exported them as .skp files and they are imported as components. So I add them and make components rather than group or layers but still when I copy components and try to place them Sketchup becomes jammed. There are about 1000 boxes to be placed on tables and each box contains 40 instruments. I have added only 40 boxes yet and my PC is irresponsive. Is there anything I can do?

Learn about SketchUp and high poly/low poly models:
https://help.sketchup.com/en/making-detailed-model-lightweight-way

Learn about SketchUp Importers and Polygon reducer:

2 Likes

Add more RAM.
Try to make similar looking parts of your model as components and scale them individual.
Your system has a slow graphics card - intel hd graphic card may work for small models, but with more complexity on your models you need a high performance graphics card to get a sufficent work performance.

Would you be able to upload one of your Fusion 360 models somewhere? It’s very likely that they can be optimized without looking different.

One thing you can do that will immediately make everything faster, is to turn off View/Edge Style/Profiles. That is a very demanding feature, and with it turned off you will be zooming and panning around the model a lot faster.

So every one of your boxes is about a million edges and half a million faces. There is no hardware that can handle a model with a billion edges. You must make your instruments simpler.

2 Likes