Sketchup to Unity3D - .fbx Asset Importing Issues


#1

Hello all,

I’ve been having an issue with seams appearing between groups of my .fbx assets I’ve imported into Unity 5. I have no clue why this issue persists, as I’m new to using Sketchup models with Unity3D. Any “good practice” tips would be greatly appreciated.

Another question I have is dealing with 1 to 1 scale when importing. I’ve read switching the Model Units to Meters in Decimal form through the ‘Model Info’ Window, but it makes it kind of hard when all of my standard dimensions are being done in feet - however, I have managed to get the scale to match up perfectly when using said technique with meters in decimal form. Would it be practical in my situation to just model everything in feet first, then when all my dimensions are correct just switch the model units to meters in the way previously mentioned?

I would love any advice you would offer. I’m just trying to get into good habits that won’t come back to bite me in the end, causing me to go back and redo a lot of work I otherwise wouldn’t have had to do.

Thank you very much for any responses you may have. I appreciate the help =]


#2

I have no experience with Unity but I do with the Unreal Engine. Sometimes, those programs run into the same problems.My suggestions are:

  1. Seams could be smoothing or mapping issues or… Maybe you can post an image illustrating your problem?

  2. check what is the native unit of Unity. (Unreal is cm). Next, model in any unit you prefer in SketchUp. In the the export fbx options you can set the exported unit (I model in mm and just set the export unit to cm there)


#3

You’re using Make, so are going via Collada I guess. Unity wants to work in meters, so import the feet and inches Collada model and set its scale factor to 0.0254, and Apply.

If you ever do use Pro, FBX may give quicker results. When exporting you can set the units to centimeters, which is what FBX naturally works in, and Unity will deal with that correctly.

You can always create a 3D game object cube, that starts off as 1 meter across. Then you can compare your SketchUp model to see if the scale factor makes sense.


#4

There are no textures or anything on the model itself. Just standard walls with nothing added. Any thoughts?


#5

A wild guess: you could try adding textures to the objects and see if you still see the seams. That could make sense because in Unreal, the mapping info is re-used bu Unreal to store light information. Maybe Unity does something similar so missing textures = artifacts?

If that doesn’t help, you could also post this question and pictures on the Unity forum. People over there will more likely recognize the seams and possible causes.