Issues with surfaces in exported FBX files

Hello everyone, I’ve been trying to make a set of modular corridor pieces for a video game I’m making as a hobby, but I’ve been having a few problems.

My original plan was to have a 2D vertical plane as a template and build my corridor pieces using that, and once I built each piece I was planning on having nobbly bits (a 5, 5, 5 cube!) above each doorway so that I can easily fit them together.

So I’ve started off with my template pictured below:

And then used the Push Pull tool to create a straight corridor, and then add the cubes on top so that I end up with this:

But when I save it I get an error message from SketchUp saying this:

So I click the button to fix the errors and get this when I choose to see the details:

So then I thought that everything was sorted and I wouldn’t have any problems…but when I try to export it as an FBX file and upload it to SketchFab I get this error:

When I tumble around it on SketchFab it looks fine, but when I try to upload any of my other corridor pieces I see messed up flickering bits on parts of each model like this on the Turn for example:

Now I haven’t UV Unwrapped any of these models yet, but I thought that SketchUp uses the material for front faces as a placeholder, doesn’t it…? Or will all my problems disappear when I UV Unwrap everything…?

Many thanks in advance for any help! :smiley:

Just in case any of you want to have a look at things first hand here’s some links from my DropBox thingummybob:

Template https://www.dropbox.com/s/rf20msqm2yvn907/corridor%20template.skp?dl=0

Straight https://www.dropbox.com/s/1mbkiuy7fra9cbx/straight.skp?dl=0

Dead End https://www.dropbox.com/s/49o1qajzcqwg97k/dead%20end.skp?dl=0

Turn https://www.dropbox.com/s/qwmt9bi8fv12vte/turn.skp?dl=0

I’ve also noticed that when I try importing the FBX files into the Unreal Engine that the Straight corridor looks fine until I build the lighting and I get this error:

And if I try and import the Turn I get this error message:

Sorry for the novel and the pic-heavy post but I wanted to include as much info as possible, thanks again for any help given! :smiley:

I had a quick look. You have some stray (internal) edges in the models. For instance the turn: see image - the top two circles. You can automatically fix those by installing ThomThom’s solid inspector plugin in SketchUp. You must group your object because it will check if the object is a solid.

On a sidenote; maybe at some time have a look at the amount of detail of the elements. Do you need that much segments in the profile in the middle?

Next; you are getting the ‘object has overlapping uvs’ in Unreal because Unreal needs a lightmap uv channel. The first uv channel is used for the texture of the object (for your metal, wood, brick material etc). A second uv channel is needed for Unreal to store its lightmaps. Unreal can create that second channel for you during import of the fbx (mostly for simple objects) BUT it needs a first uv channel to do so (it re-uses and re-arranges the uv layout of the first channel). So apply a material with a texture in SketchUp and try again. If the error still remains; you must apply a 2nd uv channel yourself in another 3d program like 3dsMax, Maya or Blender.

Finally; making modular pieces seems like a good idea BUT you need some sort of rim / element on the ‘joints’. If you don’t; you will most likely get small differences in shadow & lighting. See more here: https://forums.unrealengine.com/showthread.php?46269-Modular-Asset-Lighting-Problem

1 Like

Thanks for the reply but the Solid Inspector didn’t solve my problems. I tried it on my Straight and it just deleted EVERYTHING apart from one ‘nobbly bit’ lol :smiley:

So then I tried it on my Corridor Template and it just filled in the hole in the middle. But of course I need that hole in the middle because I want my protagonist to be able to walk down these corridors.

And now I’ve just tried it on my Turn and it’s fixed the two problems you’ve pointed out above without a problem. But now I’ve just tried to upload it to SketchFab and I’m getting the same issue with the flickering bits.

Very odd.

Sorry if this post is jumping about, I’m experimenting with things as I’m posting. I’ve now used the Corridor Template to create another Straight, but this time I’ve done the nobbly bits differently. This time I’ve drawn 4 5x5 squares, 2 on each front and back vertical faces and this time I’ve used the Push Pull tool to push towards the opposite way to create the cubes rather than drawing squares on the top and pulling them upwards and this seems to have done the trick for the Straight anyway.

I’m going to carry on doing the same things with the other modules and see how that goes. Good job that SketchUp makes creating these sorts of things VERY quick and easy, I probably would have torn what’s left of my hair out if I was trying this in Maya lol :smiley:

Thanks very much for your help, I’ll be doing my UV Unwrapping in Maya so I’ll sort out the extra channels for Unreal when I do that so that’s one problem off my list. I think I’ll also change the middle part of that corridor too as you’ve advised. Thanks again maxB, much appreciated! :smiley:

Glad it helped. It happens sometimes a shape is a bit ‘bugged’. Always best to create it in the most simple way just like you did: draw section -> extrude -> add a few lines on top for the nobbly bits -> extrude.

A suggestion: have another look at the dimensions. The elements seem rather large in size.

I had to multiply the dimensions by 100 because SketchUp and Maya and the Unreal Engine use a different scale. The models when I imported them into Maya were tiny so I had to scale them up 100 times the size. After I did that they were exactly the right size when I bunged them into the Unreal Engine.

You could also have a look at the export options for the file format you’re using going from Sketchup to Unreal/Maya (fbx / obj / …).
I model in ‘mm’ myself and in the fbx export options I choose ‘cm’ which is Unreal’s default unit. That way, there’s no need for manual scaling and you let the exporter do it for you.