SketchUp to Adobe Dimension - Graphic will not apply to face

I can import a SKP file into Adobe Dimension, apply textures, lighting effects and render with no issues. I cannot, however, seem to “Place Graphic on Model” to work correctly. I’m assuming it has to do with SketchUp and the way it segments curves/arcs, as it works perfectly with the native models. Does anyone know a workaround?

SketchUp Model:

Adobe Dimension:

I have Dimension as well but I’ve never tried this. I’ll have to find time and take a look at it.

You need to go to 'Object/Generate UVs with your SketchUp asset selected. I talked to the Dimension folks at Adobe MAX conference in LA recently about making some kind of warning or something that either ‘auto-generates’ UVs or prompt for manual generation.


Life saver!!! Thanks!
Yes, this needs to be added to the tutorials. I don’t believe anyone mentioned this simple step.

1 Like

I know! It tripped me up a bunch of times when I was getting started too.

1 Like

Funnily enough, I was able to import my models (water bottle, too) into Dimension and add graphics without having to Generate UVs. Any idea why? I didn’t model it special or anything, I just took something I had and tried it out.

Can you post or PM your water bottle SU model? Would be interested to try it out myself and see if I can find out why it worked and others don’t.

You’re right, I had to generate the UVs. I stand 100% corrected.