SketchUp Silent install

make
install
silent

#1

Hi,

I’m working for the IT direction of Paris (France)
I’m trying to deploy SketchUp make with a script for a master on Windows 7.
I use : msiexec.exe /i sketchup-x86.msi /qn and it works !
My problem is that I want to try to launch sketchup and go directly to the main interface, not the “welcome page”.
Is there any way to do that ? (parameter in the script, reg key to add, or value to change???)

Thank you for your help.


#2

No, there is not. The splash screen is one of the small prices you pay to get Make for free.


#3

You would have to buy SketchUp Pro for professional use, then launch SketchUp with the welcome dialog for the first time and then you can uncheck the setting “Show start up dialog”. On subsequent use, the welcome dialog will be skipped and the main interface will open directly.

Or you cobble something together with AutoHotKey that clicks the button. But I doubt that will work.


#4

OK. Thank you both for your answers.
Assuming i can’t bypass this, i go with it.

I have another question, butb maybe you will give me the same answer …
When you launch sketchup for the first time, after the welcome page, there’s a pop-up for the update of the product.
Is it possible to “silent it” ?

PS:excuse my english, please, but i’m french ! :slight_smile:


#5

In the Preferences->General window there is a checkbox to suppress checking for updates. I believe that on Windows it sets a per-user registry entry so, like suppressing the splash screen, it would have to be done for each user.


#6
  • Update SketchUp, if it’s up-to-date it won’t ask.
  • Once you got through to the main interface, you can also explore Window → Preferences → General. There is a checkbox called “Allow checking for updates”. I believe you could also find a registry key “CheckForUpdates”.

#7

yes, i’ve seen the checkbox in the preferences.
And it’s OK modifying the registry key Checkforupdates in the preferences HKCU\Software\SketchUp\SketchUp 2016\

Thank you for your help ! and your reactivity !


#8

This topic was automatically closed after 91 days. New replies are no longer allowed.