SketchUp Shop Challenges - What am I doing wrong?

I’ve been using Sketchup Shop (web version) on both my PC and Mac quite a bit over the last few months, making about a hundred different parts for 3d printing, but have run into a fair number of challenges. Before I throw up my hands in frustration, I wanted to see if anyone else is running into these kinds of issues as well, and maybe there’s some advice someone can offer, or maybe I’m missing something.

  1. Trimble Integration is challenging. I’ve found that I have to perform a very precise ritual when starting up SketchUp. I’ve had a number of cases where I’ve lost 20-30 minutes of a drawing because I went to save it for the first time and for whatever reason SketchUp was unable to reach trimble, or the UI just didn’t seem to be working correctly. If I make sure I open a previous file first, or save a blank part first thing, then I don’t lose anything, and I’m generally OK after that. (trimble outages and uptime are a separate topic, but this thread is about SketchUp)

  2. HotKeys, potentially specific to Sketchup Shop? First of all, there are a couple of hotkeys I’d love to have. Maybe they exist but I don’t know about them. It’s not obvious from the UI what these are - highlighted text on some of the buttons would be awesome so I could self-learn. Examples: hiding/unhiding, grouping/ungrouping, show hidden/hide hidden, make an arc using a center, radius, and angle. Secondly, why can’t I find an easy-to-use PDF that I can print when I google this? (other product counter example: hotkeys are the very first link when you google “fusion 360 hotkeys.”) Like I said, maybe I’m missing something.

  3. Arc and circle segments result in a bad user experience for me.
    a. I work in millimeters on 3d printed parts that are no bigger than 200x200x200. I’ve hit this bug a number of times - I go to make an arc and it fails and says “too many segments.” Then I need to re-cast the arc until I discover the magical number of max segments SketchUp will allow, trying and re-trying until it’s happy.
    b. It’s not obvious to me where in the arc creation sequence I have to hit the “change number of segments” buttons (which I can never remember and are not labeled as far as I can tell). It’s unclear why it just doesn’t default to a workable number of segments just like circle does - which seems to automatically figure itself out.
    c. When creating a circle, why doesn’t it default to “max number of segments possible?” I find myself almost always zooming in to increase a circle from something like 24 to 48.
    d. Setting number of segments can fail silently. I have to zoom way in to see that my changes took effect because it can and often does fail silently - it’ll accept my 48 in the UI but the actual number of segments doesn’t change.

  4. It’s better to work in large scale. The segment limitation issues are pretty profound. When I want to create a really nice part, I’m forced to work at 10x or 100x scale, and then scale down at the last minute. This seems weird? It’s also mind bending to try and work at 100x for a couple of hours and then switch over to “real size” and I’ve gotten bit by not remembering I was in 100x many times and creating parts that were too small, I had to scale up, and then of course re-place/re-anchor/re-join.

  5. Follow me fails with no explanation at times. Best way to see this is to create a part at large scale with a curve. Scale it down. Try to “follow me” on the curve. It seems to fail quite a bit - it’s like SketchUp can’t figure out how to follow that number of segments once you scale it down. It’s most often a curved surface that just doesn’t exist - follow me clearly creates the top and bottom but fails at curves.

  6. Solid tools need some additional tools, or I’m doing it wrong. This is one of my biggest disappointments - I purchased Shop so I could work with solids and I feel like the tools let me down more often than not. Quite often combining one curved solid with another curved solid results in a non-solid that I have to manually patch up. What makes this worse is that it doesn’t tell you where the issue might be - you need to guess and zoom in to figure it out. And…zooming and panning is extra hard when you’re in so tight on those little details.

  7. Why aren’t there more fonts? Or…the ability to import my own fonts? I contacted support and found out that I need to spend even more money to get a different version of sketchup with more fonts. My only option is going to be importing an image of a font from another program and turning it into a component that I can put on my parts. Is there a workaround?

  8. I’d love a way to say “make a line, starting at this point, at this angle from the blue axis.” (I’d like to type in an angle) Does this exist and I’m missing it? I really don’t want to have to make a line and then rotate it every time - this is inconvenient in some contexts.

  9. Selection of “just lines” or “just surfaces” would be awesome. I find myself wanting to “smooth” or “round” a bunch of lines on a surface (often one I’ve cleaned up from one of sketchup’s solid tools issues) and clicking on a ton of lines is pretty tedious. It would be better if the context menu where I can say “select all connected surfaces” kind of thing also included “keep only lines” or “keep only surfaces” so I could hide things or perform actions on things much more easily. Maybe this exists and I am missing it?

  10. Is there a way to turn a set of segments that used to be a circle/arc/polygon back into that? Sometimes I find that my circle/arc/polygon, due to trimming or whatever, has turned into a bunch of segments, but I want to find the center or select the entire edge, and this isn’t available anymore. It creates a lot of extra work.

It’s not a bug. The thing you are butting heads with here is when you get too many segments in a small arc or circle, the points effectively merge due to the tolerances set in the software. The reason for telling you that you’ve chosen too many sides for the arcs/circles is to prevent you from creating models that can’t be printed because they aren’t watertight. The easy solution to this is to work in meters instead of millimeters. You enter all of your dimensions as if they are milleters but units are set to Meters. STL files are unitless so it really makes no difference that the units are set to meters. Tell the slicer software that the units are millimeters when you import the STL file.

Additionally, you may not need as many sides in arcs and circles as you are setting. Depending on the printer and the application, you might be able to get by with fewer sides.

This solves your issue in #4 as well.

Show an example. Is it because you are working at such a tiny size and maxing out the number of segments? If so, my solution above will sort that out.

Here’s a quick example. The model was created using meters as the units.

I exported the STL from SketchUp, uploaded it to i.Materialise telling them the units are millimeters. No need to scale the model down before exporting.

It’s probably a scale thing, as you say, but it’s super annoying. Here’s an example I just did in a couple of minutes.

I created a new drawing, scaled it down so it’s beyond the number of segments SketchUp likes.

Then, I added a surface I wanted to revolve around the outside radius.

Finally, when I click the “follow me” on the outside radius of the cylinder and the surface I just created, this is what happens:

You’re running into the thing that the Too Many Segments message is trying to help you prevent.

How many segments in the circle you made the cylinder from?

Why scale down? As I said, there’s no need. If you feel you must scale down, do it after you’ve created the entire model. Those short edge segments and tiny faces can exist once they are created but for 3D printing, I don’t know why you would bother scaling down anyway.

I understand what you’re saying, but I don’t buy it. Here’s a part I designed in SketchUp and printed on my printer. You can clearly see the segments in the design. When circles are printed within a deposition layer (in the XY plane) the resolution on a circle is fantastic. (vertical or angled is a different story) . You can clearly see the segments from SketchUp in my drawing. The only way to fix this is to scale up/work in meters.

Also, I don’t understand what “watertight” has to do with this issue? This just seems like a floating point resolution issue in software that we’re making excuses for?

I’d really never thought of working in meters like this. This feels like an odd workaround but based on some anecdotal experiences I’ve had, I feel like this should work. Crazy.

Watertight refers to not having any holes in the surfaces like your example had after Follow Me.

If you want to just get on with modeling your parts in SketchUp, use the method I described. Set units to meters and get busy modeling.

It does work. Can you see my screenshots?

.stl are unitless, so 1m can be 1mm or 1cm or 1km.

1 Like
  1. you can edit your style to wireframe which allows you to select only edges. Doesn’t quite work for faces.

  2. Not at the moment. You can’t even do it on the desktop version without an extension.

  1. You can turn off edges and profiles, then select all.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.