Sketchup screen doesn't open

opengl
installation
su2017

#1

i had install sketchup and when i double click on it, nothing opens. I tried reinstalling it, but no soloution came.
i treid installing sketchup 2016 and it works very well.
but when i open sketchup 2017, nothing opens.
please help…


#2

Not all computers / graphics cards are fully compatible with SU 2017.

  1. If you are on Windows did you install and run the Sketchup 2017 Checkup application?
  2. Additionally, did you right click on the installer and choose “Run as Administrator”?
  3. Are your graphics drivers up to date?

#3

I know that SketchUp Make 2017 doesn’t run on my Windows 10, so I tried the described steps. According to the web site the checkup is available as part of the install process, but it doesn’t seem to be there anymore. I ran the installer without any problems, and only when I tried to launch the program did it then tell me the reason it won’t run (it requires OpenGL 3, and my Windows 10 only has OpenGL 2.1).

Is there some other place to get the checkup application?


#4

http://www.see-it-3d.co.uk/sketchuppro/sketchup-2017-checkup-utility/

I were pretty sure it’s part of the installer, but you could try the above?


#5

@colin
To use the newer versions of SketchUp you must have OpenGL 3 or better.
So your Graphics Card drivers need updating…

I see you have an Intel GC which is renown for its limitations…
There are many parallel posts about Intel GCs, check those out…

Failing that you need to install a newer, more compatible GC…


#6

Thanks, I know about what it would take to fix my issue. I was trying to help with the OP’s problem. As I know that my Windows 10 can’t run the 2017 version I thought it would be a good test case for the checkup tool.

I mainly only need to run the Windows version when trying to answer questions here. I use Parallels on my Mac, which is the part that only has OpenGL 2.1 support. I have Make 2016 installed for trying things in Windows.

Meanwhile, I just tried the checkup tool Thorleyian linked to, and it was able to show me a couple of warnings, and the error about OpenGL. Which makes it seem like it will help if OP can run the tool.


#7

The Checkup Tool on Windows is also known to be somewhat flaky…
So you don’t always get the correct results [it’s a Microsoft issue !]
There are several threads on this issue too…

There are also some 3rd-party tools to check you OpenGL version…


#8

@navgeet.s.sidhu

Open the Nvidia Control Panel, and set SketchUp to use your Nvidia 750M GPU.

Also be sure your Nvidia graphics drivers are updated.


#9

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.