SketchUp Runs Slow After CAD Import

My Sketchup 2015 runs incredibly slow. I have robust Nvidia card set to automatic and this setup has always been fine.
I imported a couple of pretty complicated DXF files and it takes forever to open groups, select, erase and explode. Program flikcers in and out of not working or working. I have purged all I can and no chage.
These are just lines and no faces. Should that be so heavy?
I have the option to use the cleanup plugin, but I am hesitant to do that because it could get rid of more then I want.
Anyone familiar to this problem?

SketchUp development is focused on performance.
Updating to 2018 won’t solve all your modeling problems, but it will provide best performance.
SketchUp Release Notes

The term “pretty complicated” doesn’t carry much meaning.
• How many Edges, Groups and Components does Model Info > Statistics indicate?

Key to efficient modeling is to bring into the model only what you need.
• How much of the DXF import is truly relevant to what you want to accomplish in SU?

Preparing a CAD file for import into SU can ease the pain.
• Make a copy of the DXF and prepare it for import into SU.
• Delete and purge all, except what you absolutely must have to work with in SU.

Starting with a CAD File in SketchUp — SketchUp Help

Consider whether importing CAD geometry is really necessary.

• If the reason behind a 2D CAD import is merely to a provide a reference, then, consider importing a PNG image of the CAD drawing.
• Imported CAD geometry can (and often does) contain gaps, overruns, may be off-axis or non-coplanar.
• Tracing imported geometry or incorporating that geometry into a model tends to propagate the errors.
• Building an accurate model on top of an imported raster image of the CAD drawing eliminates them.

How the model is rendered onscreen (the active Style) has a tremendous impact upon performance.
• A model is made of Edges and Faces and performs best when nothing more is rendered onscreen.
• Turn off shadows
• Render in Monochrome
• Turn off Back Edges, Profiles, Depth Cue, Extension, Endpoints, Jitter

How do I make SketchUp run faster? — SketchUp Sage Site

run it on a copy, and you’ll soon find out…


1 Like

Thanks Geo. I ended up importing tiff images af the drawings into sketchup and allowed for full resolution. I traces it there and finished the work in about the third of the haf the time I spent pulling out my hair in frustration trying to make the cad method work.
I have used DXF files before without much problem, but these were a tad bigger. Before I cleaned up, made faces and connected broken lines with very useful extensions.
I do not plan to upgrade to 2018 for the moment. Migrating extensions and setting up everything is much too time consuming and frustrating. I wish that SU worked out a painless upgrade. Maybe a cloudbased one, where my setup is saved and can resume working with the old setup as it was.
A new version every year is strange when often those upgrades are marginal bug fixing. Why not do like Adobe. Update when neccessary and launch new version when a big makeover has been done.
Just thinking outloud. :wink:

1 Like

I actually thought about that, but every action, werther copying, cleaning, erasing and exploding etc, took an hour and a half with fans singing in the wind. I later opened one file and put it throug cleanup and the plan practicly disappeared. :smiley:

I finally fell on the old and sturdy method of tracing an image and everything went well. Did it in half the time I so stubbornly spent trying to make this work.
By allowing for full image size in preferances I had a crisp and clear base to work on.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.