Really Slow File

sketchup
render
2016
modeling

#1

It seems that I’m running into problem after problem.

I have a simple small building I’m trying to draw in SU16. It’s two detailed shipping containers, cut out and filled in to make a coffee shop for a client. All went well, but after a while, the file got up to being 100+ MB and it got exceptionally slow. I’ve cut out a lot of things for the sake of reaching this deadline and cut down the size, but it just isn’t even improving much. It has taken upwards of 10-15 minutes for some functions to even work!

My computer specs are as reads:
Apple iMac (27in late 2013)
3.2 GHz Intel Core i5
6 GB 1600 MHz DDR3
NVIDIA GeForce GT 755M 1024 MB
4.33GB of 3.11TB Hard Drive

I’m running on SU2016


#2

A model size of 100+ MB is pretty large, especially for a product such as a shipping container module. Without seeing the file, I would suggest trying to reduce the number of faces and decreasing the number of segments in your curved elements. This would necessitate using Ourliner and may be a bit time consuming. Make use of components wherever an element is repeated in the model…an element should only appear once as an original in any model. All other instances should be a copy of a component. This saves some file size because repetitive components do not take up space in the same way an original element repeated X times would.

Other approaches could include using a plugin called CleanUp and copious use of the Purge command.


#3

Yes, firstly do purge in Window-model info- statistics. Before that, make copy of your file, just for case you will miss something purged. Its done in seconds and You will see if helped - please write back if it was helpfull.


#4

Hi Faccenda,

I’m afraid that you have accidentally triggered some features which will cause sketchup run slower. Please try to check these 2 possibilities:

  1. Turn off profiles line display. This only improves viewport speed.
  2. Close (or collapse) Outliner & Component(in model) dialogue window. I find sketchup functions will take much time more time IF these 2 windows are expanded and the file has large hierarchy.

Hope this can fix,


#5

Thank you all for the assistance. I had to literally delete a lot of unused files and such and just segment my model much like a stage in order to complete my project. I have tried everything you guys have presented and nothing seemed to improve my performance considerably enough to see results.

The biggest thing I could say is to try and ensure that your file doesn’t go above…say…50MB or you will see lag and performance issues unless you have a computer meant to process large amounts of visual information.

Being as such Sketchup is so user-friendly and has simple functionality, it is very easy to get carried away and make exceptionally complicated models that in the end make your computer run slower than an old Texas Instruments Calculator.
Thanks all for the help!