Reduce file size / Increase performance of Sketchup


#1

I have started using SketchUp within the last 6 months. My employer provided 2015 Pro (now running 2016 Pro) on a Win10 computer. My employer is a mechanical contractor and I am currently building models that are very large (300 meg, 1100+ components).

I don’t believe SU is really made for projects of this magnitude, but it has worked okay with a few very irritating snags; specifically INCREDIBLY long times to save, purge, or import new components. I recently timed a purge operation at over 10 minutes.

So, this leads me to several questions:

  • Is the file size to blame for the reduced performance of the software?
  • Is there a way to do a true external reference of components (instead of “insert” that makes a full copy in the new file) that will reduce the file size? For reference, two components in my file make up over 200 megs of the 330 meg file.
  • Is there something else to consider that may be causing the issue? For example the file seems to run much faster on my home computer (Win7, SU 2015 Pro) versus my work computer stated above. I also seemed to experience most of the problems after returning to the office after telecommuting on my home computer over the holidays, so the file was saved in 2015 and recently opened and modified in 2016.

I appreciate any help that can be offered.


#2

You are able to push SU at lot further, my main model is over 1.3GB with over 5 million polygons.

I also have very long load times however I do have a SSD drive but I don’t think it helps that much. I don’t believe there much you can do about the load times

The number of vertices in your model will have a direct relationship with the speed of a model, it will also depend on the textures size and numbers.

One trick I use is to remove unneeded components. If the coordinates of the components do not change and it’s not being needed in the main model until the final rendering. I copy this component with a reference to a second component or to 0,0,0 and paste into a separate file. Then you can delete this component from main model. The idea being that you would copy it directly back into your main model when you need it.

I’m not sure how other software handle huge and complex models, but I don’t believe we’ll see much change until software developers start developing for DirectX 12.

What hardware are you running at work?


#3

many people have noticed this for quite a while.
Try to disable: window -> model info -> file -> redefine thumbnail on save


#4

Snowman,

Thanks for your comments. Even before I got them, I had started doing the same thing (having one main full model and using smaller individual models for drawings that deleted everything unused).

As for WORK hardware, I’m not sure what all you would like to know, but it has

Intel i5-3210M CPU @ 2.5 GHz
6 GB RAM
Intel HD Graphics 4000
Logitech M705 wireless mouse


#5

maxB,

Thanks. I tried what you suggested and it had a marginal effect, reducing save time about 25%.


#6

Any ideas why it would take 10 minutes for a purge?

For further info, I have also noticed (not sure what happened) but multiple things are sluggish recently; like Win10 taking several seconds to reply to a click to change between multitasking apps, etc.