SketchUp - Problem with component when exporting using color by materials

Hello all,

I am trying to export a pdf keeping the colours of the edges defined by the materials, but when I export it some of the lines come out black.

Most of my elements are components since they repeated all over my model. I have trying applying the colour to the inside and the outside of the components and also tried colouring the edges.

The first image is how it looks on the pdf and the other one on the model

The lines that touch other elements just come out black.

If anyone knows if its possible to fix this without having to explode all my components, please help

Are you exporting these from LayOut?

Can you post the files?

Assuming you are in LayOut - what are you rendering in - Raster, Hybrid, Vector?

Have you tried turning off ‘JPG Compression’ in the output options?

Is your output quality set to high?

Hey bmike,

I am exporting them from the main application File > Export > 2D Graphics > PDF
I need them as vector, because I will edit them in Illustrator afterwards

What happens if you export from LayOut after rendering the viewports as Vector?

I tried it and the same still happens, I can only get the lines to come out on the right colours if I explode the components

To what do you have the back face color set?

Edit: I do see something similar in LayOut.

The black edges also show in the PDF export.

I wonder if @adam has any thoughts.

Are Profiles on in the style you are using?

I tried it with and without. Go the same result.

I’m not at my machine but I wonder what happens if you switch to color the edges by axis… do you still get black when objects touch?

Or what happens if you switch to color by tag?

Dave - I assume some of the parts in your model are solids and are actually joinery so this isn’t some z-fighting error or is it when 2 infinitely thin entities touch?

All of the parts in my model are solid components. I’m not sure if it’s z-fighting but when it occurs, there is a face passing behind the edge. The thing is it doesn’t happen everywhere.