SketchUp Pro will not open a new template and says not responding

SU Pro will not open a new template.
I have done a restart of my computer and a reinstall of SU 2020. The problem keeps happening and from what information I have found online it is a problem with the size of the file. I have an i7 with 24gb ram running windows 64 bit. Please help.

When you installed SketchUp 2020 did you right click on the downloaded installed and select Run as administrator from the context menu?

I have tried this as well.

Have you ensured that your Nvidia GPU is set to run SketchUp? Are its drivers up to date?

Which template are you attempting to open?

I am just try open SketchUp and start a new template.

To start SketchUp you need to have a template selected. There are a number of them included with the program. Which one are you selecting?

Simple in inches.

i have also tried this in meters

And the answer to my question about your graphics card?

I am just checking on this right now.

Make sure you have the latest graphics driver installed directly from Nvidia. Do not trust Windows to tell you if the drivers are up to date.

I am downloading it now from NVIDIA right now just to make sure.

After you install it shut the computer down–power off–and restart.

I have installed the driver and powered off my computer and turned it back on. SketchUp is still giving me the same problem.

Hold down shift as you start SU.

It looks like having a 2nd monitor was the problem. If I start SU without the 2nd monitor and then plug it back in it works.

Not sure if there is a fix for this but i can get back to work for now.

That would have been useful information.

You should be able to run SketchUp with multiple monitors set up. I have done this for many years with no problem.

yes, sorry about that.

the 2nd monitor I am using is an old LG 1080p tv

As @DaveR says, you can run SU fine with multiple monitors. However, there are frequent reports of apparent freeze of SketchUp when you disconnect a monitor that previously had some SU panels, toolbars or dialogs on it. With the monitor disconnected, SU may open them off screen and that makes SU seem to be frozen. You can search the forum for the magic sequence of keypresses to bring them back on screen (I’m not a Windows guru).

Yeah, sounds like the splash screen is opening off screen waiting for you to select a template.
Alt and space, then m, then tap any arrow and without clicking move the mouse around until the missing dialog appears.