SketchUp Pro to Blender Sharp Seams, and how to avoid this...?

pro
blender
export
obj
#1

I wanted to test out an export from SketchUpPro to Blender, and the results aren’t all that nice. Is there a way to prevent the gradation of a flat surface, and prevent ‘sharp seams’?

0 Likes

#2

Did you turn on Hidden geometry? I would guess that Blender exported a triangulated mesh with hidden lines.

Try running CleanUp on it to remove the extra geometry

https://extensions.sketchup.com/en/content/cleanup³

0 Likes

#3

what did you use for your export? [ i.e. format/plugin]

and what settings where available?

john

0 Likes

#4

Tried CleanUp - to no avail. There’s no hidden geometry. Purposely drew in the ‘quad’ style to prevent the triangulation of the mesh.

0 Likes

#5

Can you share the files? At this point, we’re just guessing, but if we could take a look at the files, we may just be able to come up with a REAL answer… maybe…

0 Likes

#6

have you had a look at the BlendUp extension?

I believe it solves many issues, although I haven’t used it myself…

john

0 Likes

#7

I do have BlendUp, and it works… But has similar results. It marks up the seams as ‘sharp’. Basically the mesh is uneditable beyond SketchUp. Looks like I need to jump into the Blender so to speak. Here is the file, and it was only a test… :wink: test_mesh.skp (25.9 KB)

0 Likes

#8

It looks like everything is smoothed… try doing a select all, then turn off Smooth and Soften, then try to export…

0 Likes

#9

Sigh, thought your solution resolved the mesh… then…

0 Likes

#10

Have you tried other formats? Blender will import a DAE file, right?

0 Likes

#11

I’m trying to prevent triangulation from happening. DAE works, but is a fantasticly awful tris. Defeats the purpose. I should just draw everything in Blender! Thanks for your help TheOnlyAaron.

0 Likes

#12

Sorry I couldn’t help more… just throwing out ideas. I might have to grab a copy of Blender to see if I can figure anything else out… for future reference!

0 Likes

#14

I found the solution by simply messing around… In Blender Spacebar - Mark Sharp - Clear, then add the modifier “Edge Split” and apply. A few steps but its worth the effort not to have to redraw everything.

Great now I can quad draw in SketchUp and move my geometry along to Unreal Engine without a hiccup!

0 Likes

#15

In your example the angle between each face is 90° so the edge split modifier is doing a very good job. However, as soon as you introduce some round corners and more complexe curvatures, this modifier can introduce improper smoothing.

BlendUp plugin for SketchUp exports the exact normals (it uses a feature introduced in Blender 2.74 called custom split normals) so you are sure that Blender is going to use the same normals than SketchUp.

As you don’t want to mark edge seams, you can deactivate this behavior in the option panel of BlendUp. See http://sketchup2blender.com/blendup-help#exportoptions

Disclaimer: I am BlendUp author

1 Like

#16

Hey Spread3d!

Is blendup still a thing? It sounds very cool!

0 Likes