Sketchup Pro Infinite Loop

It’s easy to see in the video. My friend couldn’t get this to render, sent me the skp file. I load it, and it’s pretty well unresponsive 14 out of 15 seconds until the loop repeats. Starts off at about 750MB climbs to 1450MB, then repeats.

Any ideas?

I turned off OpenGL hardware acceleration, same result.

Seems like you have a lot of extra bits on edges turned on (endpoints, extensions, profile, etc.)

Try turning those off, and your computer will handle the model better.

Is this problem particular to this file?

Yes, it’s the file, actually the chairs. I’m not the artist, I’m the wizard. He taps into my render farm remotely, I make sure that system runs smoothly.

We’re trying to sketch out a nail spa salon, and he purchased a model of the luxury spa chairs. The project was working fine before he added that in. I do know he used some plugins just to get to that point, but I’m running in a different rig, no plugins all vanilla and it’s giving the same jerkiness.

I’ve tried a few different rigs with different hardware configurations, all give the same result. There’s no indication of memory or cpu per say being the issue. Memory loads less than 20%, cpu does peg through the cycle but I mean if it was just that it should keep working instead of going into a loop.

I showed the artist this topic, said he turned down the edges and planes. It’s no longer looping, but a little slow. Says he can continue on now.

Thank you.

If you open Window: Model Info, what are the stats for edges?

Also, what is the file size of the model?

Can any Layers be turned off?

@josephkim626 is right on about the edges. If you go to View: Edge Style, is everything checked off (except Edges, if you are in Wireframe view)?
You could try turning off edges, and going to View: Faces Style and switching to Mono, or Shaded. Sometimes that speeds up rendering enough to at least let the model load.

My bet is that the chair is a monster of complex lines and heavy materials.

The .skp file is 53MB, I’m not the artist have no real understanding of what to do within this program, but I’ll have him look at your tips to tweak some more. Thanks.


Wow, that’s an astounding number of edges and faces.

For now, try hitting the Purge Unused button, and then re-saving the model. It won’t improve rendering, but it will reduce the file size and simplify the Components dialog box.

Also, minimize the dialog boxes on the sides of your screen. Hit the pins by the red X’s. You don’t want to accidentally open Components or Outliner while a model is struggling anyway.

I don’t know how complex the model needs to be for the rendering job, but in case it could possibly be reduced in complexity, here is a compilation of tips for reducing file size and speeding up rendering and agility of a model. It’s a work in progress, but it might help your friend, if you want to pass it on.

1 Like

here is the direct link. I can’t seem to paste the link directly without it embedding the slide, but if you copy this link, you can share it with your friend.

Katya’s Guide to Agile SketchUp Modeling