Sketchup pro crashes all the time Mac 10.9.5


#1

What I want to know is how much of my lost time will Trimble compensate me for, since I spend more time force-quitting than actually using the program?

No extensions active, no plug-ins. Not bug splat, just BBOD then force quit when I try to a) do anything, b) do anything, or c) do anything.


#2

I don’t work for Trimble so I won’t try to speak to your first question.

However, your experience is not typical, so there must be something specific to your system that is causing this. Please help narrow down what it might be… What major and minor release of SketchUp are you using (you can get this from the SketchUp->About SketchUp menu)? I assume you have SketchUp installed in Applications (that is, you are not trying to run it from the installation volume)? You say no extensions are “active”, but have you tried renaming the Plugins folder to make absolutely sure? Is this your first ever installation of SketchUp, or have you run it successfully before?


#3

Version 15.0.9349. My Mac has 32 gb of ram. No, not my first ever installation. I’ve used Sketchup for many years. I have not renamed the plugins folder, because it’s empty but I’ll give that a try. It may be the file (provided by architect - we are adding signs to it), because seems to be OK with my own files. How do I know if their file is corrupt?

Thanks!


#4

(This information was not worth more than the content of your first post?)

Does it crash while starting? There are ways to start MAC SU without trying to open recent files, does this help here?


#5

Yes, I know how to open SU without having to open an existing/recent file. So, no, it doesn’t crash while starting. I can even open the architect’s file; I just can’t do anything with it. I’m going to see if I can get another version of the file.
Thanks


#6

I’d be suspicious of the file provided by the architect since SketchUp seems to work fine with your own files. That alone should be enough evidence to say it isn’t a problem with your Sketchup installation.

If you need to be compensated for lost time, perhaps you should be asking the architect who supplied the bum file.


#7

Well, for starters, you should get SU 15.3.329, the latest version, to see whether the a bug causing your problem might already have been addressed. Try that and get back to us with results!


#8

I PM’d you - I’m not seeing your crashes, and specifically if you crashed today. Please put your email and subject in them so we can try to help.


#9

OK. Updated - still no good. It has got to be the architect’s file. Thanks to all for your input. Oh, and DaveR: you’re right, I should hit up the architect, but it’s hard enough to get them to pay our regular invoices!


#10

Understood.

Good luck.


#11

@Barry he isn’t crashing, he’s getting a not-responding beach ball of death (BBOD) and having to force quit the app. Maybe if he uses activity monitor to create a spin dump for you?


#12

So it really does sound like the file is the problem. What if you do Window->Model Info->statistics? Is there an inordinate amount of geometry, large number of materlals/textures, etc.? Does purge or fix errors improve matters at all?


#13

Ah, my speed reading fails again. Yea, cmd-option-escape, kill it, look at the stack to get a clue as to what / where it’s failing.


#14

Sorry, don’t know what “look at the stack” means…


#15

https://support.apple.com/kb/PH19651?viewlocale=en_US&locale=en_US

Run spindump,copy results, and paste and email me them.


#16

A problem I have had with SU files is that if there is any CAD material buried in the file. I treat CAD files like viruses- I isolate them, trace over them “export as CAD” to clean them for re-import on layer0 but I never embed CAD content (ie .dwg content from external sources) in any SU files.

Just a thought.