SketchUp Pro 2020 - 3Dconnexion Space Navigator Zoom Problem

Hi Folks
I just installed SU2020 and the Space Navigator Driver 10.6.5 (extension: 3DxSketchUp 5.1.0). It works but I have a strange problem with the zooming. When I zoom with the 3D mouse, combine with the scroll of my normal mouse to accelerate the process, the zooming jerk (stutter). With the previous driver, the two actions were working smoothly together, now they fight each other.
Does anyone have this problem?

Yes, I have the same problem. When I got the initial release of SU2020 everything was fine after I installed Space Navigator drive 10.6.5. Then SU release an “update” and now I have the same problem you do. I’m now back to using SU2019. If anyone has a fix I’d love to know. Tried updating my graphics card drivers but that did nothing. Specifically I’m not using the mouse, just the 3DConnexion, to move through the model and the screen jumps around and suddenly my model is a “dot” in middle of my screen. Just before it does that it bounces from 2 different screens. All this started with the newest release of SU2020. I would go back to the previous build if I knew how.

Possibly the two devices are fighting each other. I have no issues with the either device until used in tandem as in the video, then the stutter.

Maybe, but I have been using the same SpaceNavigator for 9 years with SU (together with a very vanilla mouse) and I never had this problem until I installed the latest build of SU Pro (Build 20.0.373 64-bit). I use the SpaceNavigator with other programs…no problems. Everything is still working just fine with SU Pro 2019 (Build 19.3.253 64-bit) as well, and it worked just fine with SU Pro 2020 until this latest build. Kinda seems likes it’s something with SketchUp Pro’s latest release. Just to be clear I have this problem (the one in the video) when I’m not touching the mouse at all. I just tried disabling the mouse completely and it makes no difference. Thanks for your jumping in this to help. Hopefully someone has a fix that’s worked for them.

You need to understand that is not to SketchUp to fix the problem but to 3Dconnexion to update their driver. I had some similar problem in the past and eventually 3Dconnexion fix the problem in an eventual version of their driver. We just need to be patient. I was just pointing out the problem to make them notice it. I presume more people post something on this forum, more the person concerned will notice it. Thx rlastrapes.

1 Like

If you really want them to notice it, you should be contacting 3Dconnexion directly instead of hoping that they are looking at the SketchUp forum.

i did

Hi, same problem I will contact 3Dconnexion as suggested

I just installed the new release this morning. v10.6.7 with the SketchUp Extension 3DxSketchup 5.1.1 and… the problem has not been fixed!!! :frowning_face: However, I can see an improvement when you are in parallel view mode.

By the way, I did contact the support. They make me do a bunch of resets and reinstalls but nothing fixed the problem and they told me that it will probably be fixed in a future release! VERY frustrating when you know they release 2 revisions so far.

It is possible that two devices trying to input to the drawing at the same time is causing a conflict. I see that is used to work, possibly Windows also had something contributing to the situation.