Sketchup Pro 2018 Installation - nowhere to enter license


#1

I currently have Make 2017 installed, and can’t get 2018 Pro to work.

I have a valid licence, but when I install, I get the splash window saying the trial period is over. Oddly though, the window appears when I mouse-over the icon in the system tray, but when I click on it, the window will not appear full size.

Tried uninstalling both versions and that did not work.

Sketchup support hasn’t made any useful suggestions yet.

Do I need my account reset? I’ve asked, but haven’t heard anything back.

Problem has been going on for months. I called the support line, but get the same useless message that they “will call me back” if I lee my name, number, and support ticket number. I’ve never gotten a call back.


#2

Have you got more than one monitor and you’ve changed your setup recently.
It could be that the license window is opening off screen.
If so you can try a method to get it onto your main screen.
Mouse over and click on the license window, then hit alt and space together, then m, then tap any arrow key, then without clicking anything move the mouse around until the license dialog comes into view.


#3

I do have a dual 2k monitor setup, but it hasn’t changes anytime recently.

I tired to do what you suggested. I mouse over, the preview of the splash screen appears. However, when I clock on it it just goes away.

Is there a WIndows Key toggle thing I should try? I seem to recall Vista did something like that.


#4

When I alt-tab, I can see the window, but then I click on it, it disappears.


#5

The point of clicking on it is to get the focus on it. Perhaps it would work better if you open SU again, the go Help/License and then alt and space…


#6

The problem is I cannot get it to maximize. I can see it in the mouse-over review, and I can see it in Alt-Tab, but clicking on it or selecting it via at-tab brings up nothing. Without getting it to maximize, I can’t enter my license info.


#7

Ok, the other option is, while you know it is open somewhere, right click on your desktop and select Screen resolution, then move the virtual monitors around until you find the license window.


#8

OK so you got me thinking “outside the bun” so to speak, and I got it to work.

I went to my display settings and set monitors to mirror so I would only have one display. I cranked the resolution down to 1920x1080. I restarted Sketchup 2018.

I could see the splash screen!

All is right with the world now.

Thanks for your help. I was so frustrated and totally ready to flame on the Phone Support. (Which I suppose I could still flame off about. . . )

I don’t like that Trimble has essentially outsourced tech support to all the users and still collects a fee for it, but you helped me resolve this in under ten minutes.


#9

Ok, glad you got there, once you have your monitor setup back to how you want it, you might want to go to Preferences/Workspace and hit the button for Reset Workspace.This should set everything to recognize the correct monitor as the main window. I don’t think it would have worked to get the license dialog back but you never know…