Sketchup PRO 2018 Crashes


#1

I installed Sketchup2018, 3 or 4 days ago and everything was working fine in both 2017 and 2018 on my mac - no problems. I created new files , installed extensions etc etc. Now when I try to open either 2017 or 2018 the program loads and then after exactly 12 seconds closes without any warning / message/ bugs splat or anything. I have tried removing the programme and preference files in the library and from the trash. I have removed them via the library and typed in the file names in Terminal. I have reinstalled 2018 and still it crashes after 12 seconds.

I am using Yosemite and the only thing I haven’t done is update this to a new OS. This is because I’m running an older version of Parallels with windows 7 and I haven’t got time to re-install the PC side.

I don’t have any problem opening Layout

Any suggestions


#2

According to the published OS requirements, SU 2018 only supports MacOS 10.11 (El Capitan) and above. If you want to try it, looks like it’s time to upgrade your OS!

From this help page: https://help.sketchup.com/en/article/36208

Compatibility Changes

SketchUp 2018
With the release of SketchUp 2018 we’ve removed support for Mac OS X 10.10 (Yosemite). There is no longer a SketchUp Make for download, our free version of SketchUp is called SketchUp Free and available in all modern web browsers.

SketchUp 2017
With the release of SketchUp 2017, we’ve removed support for 32-bit operating systems, OpenGL 2.0, and software rendering of models (as opposed to hardware acceleration). We also removed support for OS X 10.9 (Mavericks.)


#3

Thanks for the reply.

What I don’t understand is why (despite the fact SU doesn’t support my OS) a) it worked fine for 3 or 4 days without a problem and b) why SU 2017 which is supported on my OS and has been running on my machine for over a year without any problems whatsoever, now suffers from the same problem as SU 2018. It’s as if SU 2018 has loaded a file somewhere that is now being read by SU 2017 to tell it to stop running.


#4

Hi rimmo-

Although SketchUp 2018 is not officially supported on Yosemite, I’ve been running it on that OS without any trouble, so I don’t think that’s the problem.

There are no intentional connections between SketchUp 2017 and SketchUp 2018 that would make them both crash - I can think of a few reasons this could happen but they’re low probability.

I haven’t found any crash reports with your name on them - if you submitted them with a name or email address, please share that info with me and I can look them up for a diagnosis.

Cheers,
Marc


#5

Hello Marc Thanks for replying.

Where do I find a crash report ? The programmes just close. They don’t produce blug splats, error messages or anything. They just close and I’m back to my desktop.

I got 2017 running again briefly this morning. I deleted two files that I had saved to my desktop and then emptied my trash. Everything seemed to be working fine. I closed SU 2017 and came back to it a couple of hours later and… same problem. It opens, runs for a few seconds and closes. The reason why I thought there may be some form of internal connection between SU 2017 and 2018 is that until I loaded 2018 I never had any problems running SU 2017. I run Little Snitch to manage connections and have allowed every ingoing/outgoing connection for Sketchup and as I say SU 2017 worked fine with Little Snitch till I installed SU 2018.

Thanks
Simon


#6

Version 2017 and 2018 are two different applications, but they try to connect to the same servers, Maybe Little snitch is confused by this?

There is a folder in: ~User/Library/Logs/DiagnosticReports which contains crash reports


#7

I had lots of issues with LS and eventually stopped using it after many years…

I think it was either BugSplat reporter or Trimble Connect which it wouldn’t treat as being part of SU…

john


#8

Hi Mark.

I’ve submitted an email with the crash reports.

Regards

Simon


#9

Thanks. I’ve found the reports for 2017 but there aren’t any for 2018 ???.

I stopped Little Snitch running, but it made no difference, both versions still crash


#10

Thanks.

I stopped LS running (didn’t uninstall it) but it hasn’t made any difference.

Cheers
SImon


#11

Not quite sure whats going on with SU2018. Having installed my Pro upgrade last week it has resulted in the select function in 2017 to freeze, taking 30 seconds to do anything and 2018 features don’t seem to work properly either!
Creating components with the extra fields is really helpful but generating a report does not give you a total quantity if you have multiples on a single component (effectively just listing everything a single items). I attempted to upgrade my laptop too and the generate report does not work at all.

It may just be me but i wondered if anyone else is having 2018 teething problems or if the install has affected previous versions?


#12

check that Dynamic Components is up to date in SU v17 using Window >> Extension Manager in the menu…

that’s the only issue I recall effecting more than one version of SU…

john


#13

This is SO ridiculous, for more than a year, whatever sketchup I try (2017 or 2018), they won’t run on any of MBPs, which are now running 10.13.2.

We had even considered buying it, but with such support? Forget it. How can they release such awful piece of software? I’ve sent so many bugs report before!

We are still sticking with 2016 version, recovered from our backups, and any extension update will break it up. So we’re not able to use sandbox anymore.

I’m tired of googling for this issue to just find out “bug issues” like this one that solves nothing.

Sorry for looking so grumpy but have I mentioned we’ve battling with this issue since 2016?

How can I get direct contact with support?


#14

I’m on my phone but search forums for support. You should put in your profile the exact graphics card you have. Yours says MBP. It can be Intel, NVIDIA or ATI or combinations, in which being on battery might be a different card than when you’re plugged in.


#15

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.