SketchUp Pro 2017 wont launch

intel
opengl
version
graphics
driver

#1

Hi,

Installed SketchUp Pro 2017 on a machine but i get a bugsplat as soon as it launches, i dont see any SketchUp screen other than the bugsplat.

The machine has 64MB dedicated memory and 1632MB shared memory on a Intel HD 4400 graphics

Ive attached the log:
======== Starting GL ========
WGLUtils::IsExtensionFinderWindowClassRegistered: Class is not registered.
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAY1 : Intel® HD Graphics Family : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAY2 : Intel® HD Graphics Family : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAY3 : Intel® HD Graphics Family : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAYV1 : RDPDD Chained DD : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAYV2 : RDP Encoder Mirror Driver : PT 1
WGLUtils::EnumerateAttachedDisplayDevices: \.\DISPLAYV3 : RDP Reflector Display Driver : PT 1
WGLUtils::UtilsState::ctor: Max GPU perf is 1
GlInformation: Starting graphics capabilities tests.
WGLUtils::GetBestPixelFormat: Selected pixel format:
Id: 5 DBL RGBA:8-8-8-8 Depth:24 Stencil:8 MSAA:0 FF:0
WGLUtils::CreateGLContext: Creating HGLRC with wglCreateContextAttribsARB.
GlInformation: GL renderer information:
GL_VENDOR: Intel
GL_RENDERER: Intel® HD Graphics 4400
GL_VERSION: 4.0.0 - Build 9.18.10.3257
GlInformation: Compiling UberShader

Any help would be great

Thanks


#2

This is the important information:

We’ve already said (too many times for me to remember) in these forums that Intel driver versions below 4061 are bugged with many applications trying to create a OpenGL v3 context.

The SketchUp team created a pinned thread here in this Technical Issues category, that gives links directly to the Intel driver download pages:


#3

This topic was automatically closed after 91 days. New replies are no longer allowed.