SketchUp Pro 2015 crashing the Windows Explorer during installation


#1

Hello everyone,

I have downloaded the latest version of SketchUp Pro 2015 v.15.3.331 - Windows 64­-bit in order to do a company-wide rollout via SCCM; the first thing I test is the behaviour during manual installation. Every time I install it, and I have tried several machines, the installer asks me to close running programs; it asks to close the explorer service, which can’t be right, right? I can also choose not to close it, which needs to be followed by a reboot. If I choose not to close the explorer, it will crash, so the taskbar disappears and does not re-appear unless I manually run the command.

As for the SCCM deployment - it is no different; the explorer will crash during the installation.

Has anybody else experienced it? I was thinking about adding a start command for the explorer after the completed installation, but it would only be a way around it and no a very good one. To me it looks like there is a bug in the MSI file.

Any comments appreciated!

Cheers,
Bart


#2

What Windows version ?

SketchUp installs a “ThumbsUp.dll” in it’s application directory, that is a preview handler for Explorer.

But even so, I never noticed Explorer crashing during install. But Win 7 SP1 is the latest I installed on.

Let me ping @Barry, you might need a link to a special MSI download.

EDIT: Found the link Barry, and posted it 2 posts below.


#3

Hi Dan,

I’ve tested it on Win7 machines, both virtual and physical.

I’ve noticed that ThumbsUp.dll note somewhere, but I still think it’s not the right behaviour.

Thanks for spreading the word!

Bart


#4

Oh, got two questions:

(1) Did you follow the instructions here:

(2) Did you use the silent installer MSI* from the link at the bottom of this page:

*This is the special msi I was referring to (above.)


#5

Hi Dan,

The instructions refer to the .exe installer, which I haven’t tried running as my ultimate goal is to use the MSI installer. But what I’ll try to do now is extract that MSI from the .exe somehow and see if it changes anything.

I’ve downloaded the MSI from the link at the bottom of the page, but I think it’s exactly the same one I’ve been using, which gives me this (let me know if you can’t see the screenshot):

All the requirements from the bottom of the page are met.


#6

Update

I have just downloaded the .exe installer - still getting the same issue; it wants me to either close the explorer or continue followed by a restart.


#7

I understand that this is normal behaviour for applications that install files for the Explorer to use. Older versions of 64-bit SketchUp didn’t have working thumbnails for Explorer.

Anssi


#8

https://technet.microsoft.com/en-us/library/cc759262(v=ws.10).aspx

Try the msi with /i /qn options ?


#9

Hi Anssi,

Possibly, although to be honest I don’t recollect seeing that kind of behaviour with any other programs. Still doesn’t look right; just complicates things from the perspective of mass deployment. But I have found a workaround and will post it here.

Bart


#10

Hi Dan,

Thanks for your research; yes, these are the command line switches I use.

Bart


#11

Guys,

I have now added a custom parameter to the installation command line, which works both on SCCM and a manual one, which is this:

msiexec /i “SketchUpPro2015-en-x64.msi” /qn MSIRESTARTMANAGERCONTROL=Disable REBOOT=ReallySuppress

So I’m disabling the Restart Manager from our MSI package, which basically gives us the second choice from the manual installation; the installer finishes without closing the explorer and SCCM send its ‘reboot required’ message to the client, which can be postponed. I can work with that.

But still… I wouldn’t mind a bit more hassle-free installer!

Bart