Sketchup 2015 Install crashes Windows Explorer


#1

I’ve had at least 6 SU crashes over the last two days (since installing). I’m also getting Windows Explorer crashes when I try to delete a SU file. Seems like a Windows Shell violation - the Explorer crash goes away when I uninstall SU 2015.

Win7, Titan Black, all drivers up to date.


#2

Does the problem go away if you disable hardware acceleration from inside SU at Window > Preferences > OpenGL?

Do you have any extensions installed?

Did you submit the bugsplats?


#3

No extensions were installed, and 2014 was uninstalled at the time.  I did not try disabling GPU acceleration, but Windows Explorer was crashing repeatedly after fresh reboots and with no copy of SU running (when deleting 2014 .skp and .skb files).  When I uninstalled 15, I was able to delete SU files without crashing Explorer.


#4

Sounds like an issue with the thumbnail preview handler.


#5

Dan,

Yes it does, noticing that I get Explorer crashes just highlighting at Sketchup files from Windows Explorer. Explorer tries to restart, then fails, crashing back to the desktop.


#6

Hi all, I have been experimenting similar issue when deleting,
I had 2014 installed when I installed SU 2015, now, only SU 2015 and got few plugins installed.

Maybe is a issue with the preview as suggested by Dan?.

Working with W7 home premium…


#7

I am having the same problem at at work. My work computer is running Windows 7 Professional. I have not had this problem on my home computer, which also runs W7 Pro. My home computer has the preview pane disabled, and runs Windows on its most basic settings (no translucent panes or fancy backgrounds) in order to conserve all of the computer’s resources for massive amounts of SketchUp use.


#8

For the Windows Explorer crashes, see my post in this thread (near bottom):


#9

Thanks very much. I’d changed the name for “ThumbsUp.dll” and it works.

Cheers.


#10

I’m having the same issue. I’ll try the .dll file rename fix but does anyone know if this is a bug that is being addressed? The thumbnail preview is nice to have.


#11

I’m having the exact same problem. Renaming the DLL file solves it. I have a Nvidia Quadro K600 I wonder if that’s related to that. I know Sketchup 8 has problems with that card


#12

Have you tried downloading the latest v2015 installer ?
Trimble did an update to M1 on Friday, but for some arcane reason they have so far been unable to announce it properly to the public…
It is purported to fix some crashes…


Sketchup files cause Windows Explorer to crash
#13

We’ve been able to replicate this issue with our in-house testing. That’s good new because now we can investigate ways to resolve it. Woo woo!

For now, continue to rename the thumbsup.dll file as a work around…


#14

I have also mentioned some weirdness in the Registry settings for ThumbsUp.dll since v2014 - LayOut AND SketchUp have the ThumbsUpdll BUT only the LayOut one ever referenced to SKP etc - this was posted “elsewhere”, although @Tommy should know where I mean… :smile:


#15

When I got to work today and fired up SketchUp, it told me there was a new version available. I downloaded it and got to work. Now after lunch I’m getting the windows explorer crash issue again. I renamed the new Thumbsup.dll file, but it’s still crashing windows explorer after restarting the system.

I’m losing productivity!


#16

It seems important that both the dll files for Layout and Sketchup be renamed in order to fully resolve the issue. I also installed the latest service release this morning and encountered this crash again, was hoping that it would have been resolved.


#17

I’m curious if you both rebooted your computers after installing the update.
Just a thought.


#18

Hello pfaff, stephen,box,

A fix for this crash is not in the update posted today.

Yogesh


#19

Hi @yogesh

I’ve nothing to add.
Just adding this link to the Release Notes so folks don’t have to search for them.


#20

I fixed it again this time by renaming the ThumbsUp.dll file in the layout program files as well.