Sketchup only software on my PC running slow (Rhino, 3ds Max, Adobe all fast)

Hi,

I’m a new sketchup user, with the intent to use for architectural design (education).
I’ve wanted to import my Rhino 5 model into sketchup, and have encountered big performance issues.
Very laggy, very slow, even when there is no model or information on the screen (if i create a blank sketchup document its still slow).
I’m curious if it has anything to do with the high DPI of my laptop (I have a dell M3800).
Is there any way i can run sketchup at a lower resolution or anything?

Thanks,
John

First, lets set aside a lot of issues that importing Rhino file can do to SketchUp performance.

Can do describe the “slow/laggy” a bit better?

Is it slow whilst doing orbit and zooming? (navigation)
or opening and saving file is slow?

I suppose high resolution of the screen can contribute to the performance. But, your machine is powerful enough to swim around the model freely - given that model isn’t unnecessarily heavy, like the ones you import from other softwares.

My suspicion goes to the OpenGL settings and your graphics card driver not talking to each other properly.
This might just be a settings issue.

https://help.sketchup.com/en/article/114278

Make sure your hardware acceleration is checked and working properly.

what does “Window > Model Information > Statistics > Entire Model” show:

2 Likes