Sketchup online work "not found or invalid"

Hi.

I’ve worked on creating a model for the construction of my house. I’ve worked on this all day until morning only to find out the next day that it crashed. I’ve worked really hard on it. Kindly fix this.

If not, please let me know how it can be recovered. While the file is available for viewing at Trimble, the quality isn’t as good and I still hope to add/modify more.

I’m also thinking of subscribing for sketch up to teach in my class, now that we’ve gone all digital. But this might be a problem if some of the students encounter the same issue and makes it an excuse.

I’m using a Macbook Air. The file is available in the thumbnail but when I try to open it, it is showing “File not found or invalid” and opens an empty workspace. It’s a terrible experience to see all your hardwork reduced to nothing in an instant with no explanation. Please help. Thank you.

What browser is used? Best supported are Chrome and Edge.

If available for viewing, you should be able to download it from connect.trimble.com and have a copy on your machine.
Which can be uploaded.

Try to open it in another browser, or clear the caches and boot the machine to start fresh.