Sketchup Not Responding After Choosing Template

I launch Sketchup, I select the template, and click “Start Using Sketchup”. Sketchup then begins to load and loads the basic tool bar and some information about various tools to the right and then stops responding until I ctrl+alt+del to close the page. To clear up other matters I have tried that people have posted about already in other threads:
I’ve tried reinstalling SU
I’ve tried reinstalling the various C++ versions
I’ve run both the program and the installer as an administator
Graphics card is definitely not the issue nor is updating graphic drivers (tried before and after updating these). It is also definitely using the correct card and not the integrated one.

I don’t know why this is happening so if anyone has any other ideas…?

(ps. After the 2017 version didn’t work I tried the 2016 version figuring I’d be able to do what I needed with that, except the same thing happened; if that’s relevant)

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.