Sketchup not displaying faces properly

Hi I’ve just installed sketchup 2018, there seems to be somethin wrong with this version on my computer as it is not displaying faces correctly. My last sktechup was version 2015 and no issues aside from not being able to download from warehouse anymore. Please find example below. Any help is much appreciated!

That looks like an graphic issue. If you are on a laptop, make sure you have the latest drivers for your NVIDIA, rightclick on an empty space of the desktop and choose Nvidia settings, 3D Programs and add SketchUp 2018 to the programs that need to use the ‘Strong Dedicated VideoCard’ (and hit Ápply changes’)

In SketchUp, you can check if it uses it : [menu]Window->Preferences->OpenGL->Graphic Card Details

1 Like

I dont see any NVIDIA setting option on there
:s

On where?

On my desktop when i right click, on the menu that appears there is no NVIDIA option.

1 Like

So what do you see in the OpenGL panel when you go to SketchUp’s Preferences as directed, above?

Your profile indicates that you have a NVIDIA GeForce GTX 680MX 2 GB. If the option doesn’t show up, you’re not using it.

Install the latest drivers:
https://www.nvidia.com/Download/index.aspx