SketchUp Needs OpenGL 3.x version or high

Hi, i’m new on sketchup.

I just install the software (2019 version) and got the problem, i need OpenGL version of three, mine now is 2.1.0.

can somebody help me with it? i have tried to update the software of my graphic and follow tutorial on internet to fix it, but none of those worked.

thank you very much.

Maybe your graphic card is too old to support the latest SketchUp version. Maintaining support for old, outdated technology comes with extra work and extra costs. When doing the large rewrite of the SketchUp graphic pipeline the developers went with modern technology and dropped support for older OpenGL versions.

You can check if an older version works: https://www.sketchup.com/download/all

I think the rendering pipeline rewrite was done in SketchUp 2018 but can’t remember for sure.

1 Like

I think it was 2017, so there may be no officially available versions that use OpenGL 2.1 any more.

O think the German reseller has a comprehensive download archive but I can’t remember the address to it.

Here you go.

2 Likes

thank you guys for respond my problem

hey box, thanks, i have tried Make 2015 version, and it worked

the SU rev. 2016 is the last version running w/ OGL v2.1 and allows also to disable OGL on the GPU by deactivating “Window > Preferences > OpenGL > Use Hardware Acceleration”.

3 Likes