OpenGL version 3.0


#1

The laptop in my shop is an old Acer that works flawlessly with SU2106, unfortunately the Acer has OpenGL version 2.1. It has Intel graphics that is up to date. I’m sure there is no workaround for this, but I thought I’d ask. The Viewer also requires 3.0, which is really all I do in the shop anyway.


#2

you could use my.sketchup in the shop…

then you can make changes as well…

john


#3

Thanks @john_drivenupthewall, I saw that sometime ago but put it out of my mind because I didn’t need it, will give it a look.


#4

Unfortunately, my.sketchup.com also has the same OpenGL 3.0 requirements as the desktop SketchUp 2017.

Your only recourse, other than getting a new computer, is to back save your models to v2016 format.


#5

@DanRathbun? http://help.sketchup.com/en/article/3000316#understand-need

my.sketchup.com does not use OpenGL, it uses WebGL.


#6

which uses OpenGL.


#7

and is not the same as OpenGL 3.0. Sheez, folks, just let the guy try my.sketchup.com and figure it out.


#9

He’s viewing models, did you read that part? It’s the same viewer as 3DWarehouse viewer, so if @rboppy wants to save a private copy to 3DWarehouse, then render it full screen on his iPad or iPhone (yes, it works on my iPhone if I give it the memory it needs), that’s the same thing and OK.

Man, you guys are failure-driven today, aren’t you?


#10

I’m not doing anything commercially, I’m a retired EE, the wood shop is my hobby. I just saved a project in 2017 and will try my.sketchup.com later today and report back.


#12

My.SketchUp.com works in the shop on my Acer computer. There is an anomaly though, scrolling with the wheel on my trackball jumps a very larger distance, from full screen to almost unrecognizable with just one “click”.

I just ran SketchUp 2016, then went back to my.sketchup.com and the scrolling was normal.

Then after writing the previous sentence, I check it again and it went back to big jumps, and I can’t get it back to normal.


#13

I’ll look at that - I think we have an Acer around here somewhere. In the mean time, I’d set up Scenes to look at what you want, go full screen, and just toggle back and forth between the scenes.


#14

Thanks Barry, good idea.


#15

The computer in my office is a Toshiba, it it has the same problem. I’m using Chrome, and at both locations I use a Logitech M570 Trackball.


#16

What I really meant is that it (my.sketchup.com) had the same graphics requirements (as desktop SketchUp 2017) with regard to OpenGL support.

Previously, If the machine would not run desktop SketchUp (because of an ancient graphics that support OpenGL 2.1 max [like my coding machine],) it likely would not run my.sketchup.com either.

I had asked for a release notification thread, where major announcements of updates, revisions, etc. could be posted, and which we could “track” (watch) here in the forums.

([Insert]: This has not yet been done, and some excuses were given at the time about too many changes happening to implement, … or similar.)

SO, it comes as a complete surprise that my ancient Dell limited to OpenGL 2.1 now runs my.sketchup.com !

We were led to believe such machines would never run it, so I gave up even trying to run it on this old machine. In fact, I gave up even testing it for the most part.

There are no release notes anywhere that I can find.

None here:
http://help.sketchup.com/en/mysketchup

None in the forums. Ie, No update posting in this thread:
System requirements for launching my.sketchup

So this insult:

… is uncalled for !

Without the proper information, we are bound to fail.

With the information kept secret, we are set up to fail.

Then to “rub our faces” in facts only you are privy to, is infuriating!


#17

Did not mean to be infuriating… I advocate for you guys internally, which is why I get snippy externally. If I’m upsetting internals with their lack of publicly visible versioning (that’s happened twice in the past two weeks), and upsetting you externally by pushing back when you think you know more than you do, then maybe I’m not in such a bad place. I wish we could all be as nice online as @DaveR… I’ll settle for trying to be that nice in person and not worry about online.

I have a way of looking at what version is running in my.sketchup.com… I’m not sure it’ll tell you much, but I can say that we push it and 3dwarehouse at least every 2 weeks, and the current version on My was pushed a week ago. In the early days of 3dwarehouse at Trimble, we tried doing 2 week release note updates. We simply ran out of cycles to do this. The way web apps are pushed today, we begin pushing parts of a feature long before the entire feature is ready. And sometimes it’s hard to define when a feature is actually there or complete.

We’ll try to clean this up a bit.


#18

@rboppy, have you tried plugging in a cheap wheeled mouse in your Acer to use instead of using the trackball?


#19

Interesting, I tried it on my Chromebook with a wireless Logitech wheel mouse (M305), and everything worked great! I’ll try this mouse in the shop tomorrow.


#20

In the shop the M305 gave me the same results as the trackball, tried a wired Logitech wheel mouse and it works fine. I have several more wireless mice and when I have time I’ll check them too, they are all Logitech so I don’t expect much luck.


#21

More information. The problem seems to be related to the Logitech wireless software. With the M305 plugged in, I start my.su and the anomaly is there. When I plug in another Logitech usb receiver for a different mouse the anomaly goes away, but if I leave the page and visit another web site, when I come back to my.sketchup.com the problem is back.

I did this testing on my Toshiba computer since it has the same problems as the Acer, it’s a lot more comfortable here in my office.