Visualizer - How to Install for SketchUp 2016

Hi Denis. I browser the topics each day and offer people my insight into things related to sketchup.
People are trying to render a sketchup model with visualizer because they may think it is quick and easy.
All that I am saying our pointing is… tI am pointing them to the elevator rather than the stairs to get to the top floor. If I saw someone digging a hole with a spoon surely one would say, why don’t you use a shovel. Its the same in sketchup if someone is drawing a box with the line tool most people in the room would say why not use the retangle tool and pushpull.
Surely this is what the forums are about. If there is a better way one should say.

No, this thread has a clear title for it’s intended audience…

for the many mac users of Visualizer, that can’t even run Brighter, your interjections are pointless…

you should start your own thread i.e. Visualizer v Brighter for beginners…

then when all the Vray/etc… fanboys storm in, you can ask them to do the same…

The fact that ‘you’ can’t get good results doesn’t mean that others can’t…

john

3 Likes

This method works if you already had/have Sketchup 2015 installed and are migrating to 2016. Has anyone figured out a workaround for fresh installs of 2016 & Visualizer? I’d even be happy for a link to Sketchup 2015 make and do install that if I have to I just can’t find one.

If your brave enough, you could see if you can ‘trick’ it into installing for v15…

if you change the v16 folder name in ‘Finder’ the installer may, install into a v15 Library path which it makes itself anyway…

depends how deep it looks, it may not be any deeper than that…

john

So after a little googling I figured out “finder” is an Apple program (I’m on windows) so that didn’t work. I was inspired by your suggestion though and did try to rename my sketchup 2016 to sketchup 2015 but it didn’t work (I’m guessing the installer checks registry keys). I attempted to disassemble the installer but found there’s a “data” file that I can’t open (in hopes of finding the applicable folder and files). Thanks for the suggestion though!

Windows 7/8:
SketchUp Make 2015-EN x32
SketchUp Make 2015-EN x64

Mac OS X v10.8/9/10:
SketchUp Make 2015-EN

non-commercial use only!

1 Like

Thank you SO VERY MUCH!!

Hello all,
I have been trying to load the Visualizer program into 2016 as described and each time I get a load error. I see it in my extension library under preferences - and it is checked - but it does come up under Extensions when I run Sketchup. Can anyone help? Below is the error record that keeps coming up.
Thanks
Error: #<LoadError: cannot load such file – ImaginationVisualizer/Extensions/IRExtension2015>
/Applications/SketchUp 2016/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.0/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in require' /Applications/SketchUp 2016/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.0/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:inrequire’
/users/michaellannen1/library/application support/sketchup 2016/sketchup/plugins/imaginationvisualizer/iv_initialize.rbs:67:in <module:ImgTecVis>' /users/michaellannen1/library/application support/sketchup 2016/sketchup/plugins/imaginationvisualizer/iv_initialize.rbs:10:in
/Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer/iv_loader.rb:5:in eval' /Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer/iv_loader.rb:5:inrequire’
/Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer/iv_loader.rb:5:in <top (required)>' /Applications/SketchUp 2016/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:inrequire’
/Applications/SketchUp 2016/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in load' /Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer.rb:25:inregister_extension’
/Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer.rb:25:in <module:ImgTecVis>' /Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer.rb:14:in<top (required)>‘
Error: #<NoMethodError: undefined method get_imgtec_rnd_api' for nil:NilClass> /users/michaellannen1/library/application support/sketchup 2016/sketchup/plugins/imaginationvisualizer/iv_initialize.rbs:23:inirapi’
/users/michaellannen1/library/application support/sketchup 2016/sketchup/plugins/imaginationvisualizer/iv_menu_commands.rbs:26:in <module:ImgTecVis>' /users/michaellannen1/library/application support/sketchup 2016/sketchup/plugins/imaginationvisualizer/iv_menu_commands.rbs:10:in
/users/michaellannen1/library/application support/sketchup 2016/sketchup/plugins/imaginationvisualizer/iv_menus.rbs:9:in eval' /users/michaellannen1/library/application support/sketchup 2016/sketchup/plugins/imaginationvisualizer/iv_menus.rbs:9:inrequire’
/users/michaellannen1/library/application support/sketchup 2016/sketchup/plugins/imaginationvisualizer/iv_menus.rbs:9:in <main>' /Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer/iv_loader.rb:6:ineval’
/Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer/iv_loader.rb:6:in require' /Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer/iv_loader.rb:6:in<top (required)>’
/Applications/SketchUp 2016/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in require' /Applications/SketchUp 2016/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:inload’
/Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer.rb:25:in register_extension' /Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer.rb:25:inmodule:ImgTecVis
/Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer.rb:14:in <top (required)>' Error: #<NoMethodError: undefined methodenable_statistics’ for nil:NilClass>
/users/michaellannen1/library/application support/sketchup 2016/sketchup/plugins/imaginationvisualizer/iv_menus.rbs:93:in <module:ImgTecVis>' /users/michaellannen1/library/application support/sketchup 2016/sketchup/plugins/imaginationvisualizer/iv_menus.rbs:12:in
/Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer/iv_loader.rb:6:in eval' /Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer/iv_loader.rb:6:inrequire’
/Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer/iv_loader.rb:6:in <top (required)>' /Applications/SketchUp 2016/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:inrequire’
/Applications/SketchUp 2016/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in load' /Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer.rb:25:inregister_extension’
/Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer.rb:25:in <module:ImgTecVis>' /Users/michaellannen1/Library/Application Support/SketchUp 2016/SketchUp/Plugins/ImaginationVisualizer.rb:14:in<top (required)>’

did you ever run it in SU v15?

it looks like it not ‘finding’ the app in your Applications folder…

if you right click the app itself, you may get a error, but OS X should then know where to find it… [maybe]

john

Thanks John - I will give that a try. I did run it in my old version of 2015 - but I removed that version and then when I wanted to get my Visualizer back I downloaded 2015 again so that I could download Visualizer - and no I didn’t ever run it in 2015 after this new download of both.
I will try the right click method. I’ll let you know how it goes.
Thanks again & again
Michael

Nope. I right clicked the program in the applications folder and I opened Sketchup 2015 and ran Visualizer - but no luck when I reopened Sketchup 2016 - still got the same error message - or at least I assume it was the same error message. Any other possible solutions?
Thanks
Michael

did you manage to save an image from the new v15 install?

if so, you could try to copy /paste the v15 [working] files into the v16 folder, over writing the previous attempt to see if that works…

the next step would be finding and trashing .plists using Terminal.app…

it woks for me and others so it’s only a mater of finding and reconnecting the missing link…

john

Hello John,
Not sure what your referring to - I do have saved copies of images from my 2015 Sketchup of Visualizers images - if I copied them where would I try to pasted them in the 2016 version of Sketchup. And again not sure what trashing .plists refers to - and no idea what Terminal app is. ?
Thanks for the help
Michael

no, I was referring to the Visualzer plugin files…
i,e, first confirm it still works in v15 by using it , and then move a copy of those Visualzer plugin files…

john

Hi all,

I am also trying to install Visualizer into Sketch Up Pro 2016, I have been using it in the past for Sketch Up Make 2015. I’ve tried following the instructions above but my results are slightly different.

Firstly, when I go “Finder”, then “Applications”, My Imagination Visualizer app sits on its own within the applications folder, it’s not within my Sketch Up 2015 folder. I’ve tried copying just the Visualizer app but it doesn’t register when I open SU 2016.

In “Preferences” within Sketch Up 2016, I’ve tried “install extension” and it maps me to my apps folder, but I’m not able to select Imagination Visualizer as it’s greyed out. Also within this Preferences box, Visualizer is not listed in the list for me to tick.

Worth noting that I’m on a Mac and I a currently using a free trial of Sketch Up Pro 2016.

Can someone please advise?

Thanks!

that is where it should be, the ‘extension/plugin’ files are what require moving…

there are clear instructions at top start of this thread click here

good luck

john

Hello John & Shanna, - and everybody else out there,
I have pretty much the same issues that Shanna has - now after fooling with it so much I have lost the Visualizer folder and rb icon. I had removed the folders from my 2015 Sketchup but the program would still show up and run on my extension’s tab - even though it would not show up in my preferences/extension window. So I completely erased the Visualizer app from my apps window and then it would not run in 2015 anymore. So I reinstalled the program and tried to add the plugin back into 2015 Sketchup but like Shanna it was now greyed out and could not be installed. So I then copied Visualizer from my apps program went into the plugins for 2015 as described above and just pasted the app into the plugin’s folder. Went back to 2015 and ran Visualizer and it ran perfect - but still would not show up in my preferences/extension window.
This is of course like someone who has driven a car all their life but never had an idea whats under the hood - broken down in the desert and moving wires about in the engine compartment trying to see if moving one will save them.
Anyways I did the same with 2016 Sketchup - copied the app from the apps folder and pasted it into the plugin’s folder in 2016 - but this time I got no results and am not getting load errors reports either. 2016 fires up and runs as normal but no recognition of Visualizer. It all makes me sad because I loved that program and am trial testing a couple other ones but they just do not have the simplicity or character of that I prefer in Visualizer - and the simplicity is key at this point - I’ve not the time right now to go through and figure out all the rendering choices that the trials I’m using require- one being Twilight V2 as well as Ambient occlusion. If nothing else can anybody recommend a similar program to Visualizer.
Hope this doesn’t sound like I’m whining - just frustrated that my favorite toy was taken away - and yes I would like to whine and cry about it - but I’m not - lol - but trying hard to get it back from the bullies who took it away.
Thanks much for all the help everybody
Michael

The Visualizer App needs to be in the applications folder:
Then you need to copy the plugin from Library->Application Support-> SketchUp 2015 to SketchUp 2016:

I hope that helps.

I agree that you should put the app back where it belongs…

here’s a ruby script to copy the v15 file into v16 Plugins folder…

copy/paste into the bottom of Ruby Console and hit return, restart SU…

v15_folder = "/Library/Application Support/SketchUp 2015/SketchUp/Plugins/ImaginationVisualizer"
v15_extension = v15_folder + '.rb'

v16_folder = File.expand_path("~") + v15_folder.sub('5', '6')
v16_extension = v16_folder + '.rb'

command = 'ditto ' + v15_folder.inspect + ' ' + v16_folder.inspect + ' && ' + \
'ditto ' + v15_extension.inspect + ' ' + v16_extension.inspect

system(command)

john

2 Likes

Hello to you guys,
Thank you, Thank you, Thank you!!! I can’t say it enough times. I did the copy/paste to the Ruby console and
Visualizer is working in 2016. I really can’t tell you how grateful I am that you guys will take the time to be patient enough to get numbskulls like me through these things. Your are the greatest!!
Have a wonderful weekend and pat yourselves on the back for helping out a lost fool.
Take care
Michael

1 Like