SketchUp modified Axes don't reflect in Layout


#1

Is this a bug or am I doing something wrong?
I geolocated a model, then, in order to have elevations views, I modified the master Axes in SketchUp.
For some reason, Layout (and SketchUp too) default views (Front, Back etc) preserve original model Axes.

How could I fix this?


#2

if you have scenes set-up the axes may only be being saved to that particular scene and revert back to default position on other scenes?


#3

In SketchUp the standard views always use the systems axes. New drawing axes have no effect. If you change axes and right click on an axes and select ‘Align View’ in the context menu, green will point up on screen. You can use this feature to create the appropriate scenes for both SketchUpp and LayOut.


#4

As @Wo3Dan, indicated, the standard views are fix an independent of the model axis orientation. Set upi scenes in your model to show the elevations as appropriate for the geo-located model. If the front of the building faces north, you’ll need to use the standard Back view as your front.

You should be making scenes in SketchUp that show the desired views. Then, select those scenes in LayOut for the various viewports and don’t touch the “Standard Views” drop down list in the SketchUp model panel in LayOut. You only need to select the scene for the view you established in SketchUp.


#5

So, creating Scenes is the workaround
Ok, thank you all :slight_smile:


#6

It’s not a workaround. It’s the intended workflow.


#7

:thinking: I’m not so sure about that…
If so, what’s the benefit of standard views (buttons) when you geolocate a model?


#8

There are a number of settings and options available in LayOut for dealing with the SketchUp viewport that can be useful for one off documents but anything you do that makes the scene show as modified disconnects the viewport from the SketchUp scene so that scene specific changes you make in LayOut won’t get carried over to the viewport when you update the reference. The forum is full of examples where users have created problems for themselves by modifying scenes in LayOut.

You can select the standard views in the SketchUp Model panel if you want but that modifies the scene. If you set up the desired view as a scene in SketchUp and select that scene for the viewport, there’s no need to select the standard view in the SketchUp Model panel in LayOut. It takes care of itself.

No matter what, the standard views are fixed in SketchUp and are not connected to the axis alignment. If your building faces north and you want to show the front elevation, you’ll need to choose the Back view instead of the Front.


#9

@marcodileo,

And if your building does not face north, then in SketchUp set up the scene according to what is highlighted in my previous post. Select that scene in LayOut.


#10

@Wo3Dan @DaveR
Yeah guys, and that’s fine, I mean: it works. I’m fine with this steps.

But, imagine I have to do a quick sketch and layout-print it: I geolocate a model, align axes and start 3d modeling-sketching.
Why should I go trough Scenes when I just need 4 (standard) elevations, that SketchUp already gives me?

I just believe that, when I change axes, the standard views buttons should align to my new axes. That’s why I was calling it a workaround.


#11

You don’t have to, if you manually geo-locate the model.


#12

What I found for myself, it could be much easier to save the building/structure component, open it separately - all axes will be as as you set them. And you will get 2 models:

  1. geolocated one. With building as a component
  2. saved building, with axes as you want them to be.

And later it is just couple of seconds to get sub-model “2” into main model “1”.
As you can combine different models easily in Layout document, this should be OK.