Issue with standard views while inside component edits

Hi All,
Since upgrading to 2022 I found that when I use standard views while inside a component, they align with the components internal axis rather than the world axis. This must be something new as I never noticed before, I use a lot of components in my drawing and they are in all sorts of rotations, this new feature is causing me some head aches, is there a way of turning this off so standard views stay true to world axis…?


Yes. Standard views now align to the axes in the current context. This feature was added in SU2022 after many requests for the feature.

Thanks for the response,
I guess we all work differently, but for me this is acting more like a bug than a useful feature.
Mainly because I have to often align components within components to other objects outside of my component. And the view I get is completely disorientating when I have a busy model,
So there’s no way to revert back to the old way other than going back to 2021 I assume.?
Maybe be useful to add a shift option, so if you press shift and the view you need it stays with world axis…

No. there’s no way short of going back a version or changing your workflow.

It never fails, though. A feature that so many people have demanded to have is finally implemented and someone thinks it’s a bug.

I can see how it could be useful,
It just doesn’t suit the way I work,
I’m sure there’s lots of happy users enjoying this update, for me I’ve lost some sketchup, if I intend to keep upto date with the latest updates.
I’ll figure out a workaround, I was just seeing if there’s a way to disable this, or if there was a shift option like I mentioned earlier…

You can create a scene in which the only saved property is the axes location, and if you click that scene tab while editing a group, it will take effect until you exit. There’s another thread where it’s been asked to make that axes setting persist.

One way (per editing session) is mentioned above by @RTCool : create a proper scene(tab) with only the systems axes saved. Click the tab > followed by selecting the desired standard views.
Occasionally (say no scene as mentioned above available) you could also right click on a local object’s axis > reset > and use the desired standard views.

p.s. the resetted axes won’t stick to the objects. Their local axes do not change, unlike when using the ‘Axes’ tool or when using ‘Change Axes’ for components.

1 Like